27

I have a running log, it outputs a lot to the terminal. Unfortunately, when I try to scroll up and view older output, it appears there is a limit. And I am unable to scroll past a certain point. On the Mac, the terminal allows you to scroll up to the start of the session. Is there a way to do this in ubuntu terminal?

  • 1
    konsole, the terminal program from KDE, has a setting to control the number of "scrollback" lines it remembers, including Unlimited setting. I suppose Gnome terminal should have something similar but I can't check at the moment. – Sergey Dec 11 '12 at 0:57
32

Go to Edit -> Profile Preference -> Scrolling Tab

Now just tick the Unlimited box below Scrollback.

You will now be able to see your entire output.

enter image description here

|improve this answer|||||
  • @JohnMerlino If the answer was useful to you, Consider upvoting the answer – Hashken Dec 11 '12 at 2:16
  • where find Edit option.??? – vineet May 31 '16 at 6:09
  • 1
    In your Menubar – Hashken Jun 1 '16 at 6:53
  • @vineet_sah: There's no 'edit' in my menu bar. Instead, I right-click inside the terminal and select "Profiles -> Profile Preferences" – Jeff Learman Nov 21 '16 at 20:06
  • 1
    what about with ubuntu server without UI? – RollRoll Mar 24 '18 at 1:18
11

Since the question is now over three years old, I just want to post an update:

In Ubuntu 15.10 it is pretty similar to the accepted answer, there it looks the following:

  • Go to Edit -> Profile Preference -> Scrolling Tab.

  • Untick the box beside "Limit scrollback to:".

Disable "Limit scrollback to:"

|improve this answer|||||
  • Is there any danger to the unlimited setting? Like e.g. running out of memory? – becko Oct 23 '19 at 8:33
2

Supposedly Gnome terminal has an option for that, please check Edit->Profiles->Default->Edit->Scrolling->Scrollback

|improve this answer|||||
1

The other answers here are correct... unless you use the clear command. Sometime after Ubuntu 12.04, running clear also prevented scrollback, even if you have the terminal set to unlimited scrolling. This can be very frustrating.

For a discussion and workarounds, see How to stop `clear` from clearing scrollback buffer

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.