8

This is a very difficult thing to search for, and find an answer to because of the unfortunate choice VMWare and Ubuntu both having something called "Unity". My host operating system is Windows 7 - 64 bit, running VMWare Workstation 9.0.1. I have a virtual machine running Ubuntu 12.10 - 64 bit. When I attempt to put VMWare in "Unity mode", I get the following message:

The virtual machine cannot enter Unity mode because:
- Unity is not supported on the guest operating system.

From the VMWare site, there is nothing listed that says that Ubuntu is not supported for this... and I have installed the latest vmware-tools on the guest operating system. It seems like a lot of people have had this issue, but I haven't seen a good resolution to it yet. Does anyone know how to get Unity mode working with Ubuntu?

12

I had the same problem. I thought it is just Ubuntu 12.10, so I setup 12.04 in Vmware Workstation 9 and had the same result. You're right, it's hard to find the solution for this. The problem is Unity Desktop (in Ubuntu), so I switched to gnome3.

sudo add-apt-repository ppa:gnome3-team/gnome3

sudo apt-get update

sudo apt-get install gnome-shell

Log out and click the circle to change between desktop environment

Resources: http://communities.vmware.com/message/2139647

http://ubuntuxtreme.com/howto/how-to-change-desktop-environment-in-ubuntu-12-10/

2
  • 2
    Thanks. Interesting, I tried with the three different Gnome modes and only one behaved as I would like. The one labeled "Gnome" went into Unity, but took over all my monitors, even for one app. Gnome Classic wouldn't go into Unity mode at all. Gnome Classic - No Effects worked as I expected.
    – Nick
    Dec 11 '12 at 15:02
  • ubuntu 13.10 gnome desktop, unity fusion cannot be turned on as well.
    – zinking
    Sep 7 '14 at 12:31
7

My two cents.

I've installed several flavors of Ubuntu on virtual machines, using both VMware Player and Virtualbox, and Vincent's answer is absolutely correct. VMware hates the Ubuntu desktop called Unity (unfortunately, as mentioned before, this shares a name with VMware's own Unity Mode). This is just one more reason to avoid Ubuntu's proprietary desktop.

My suggestion, is you MUST use Ubuntu, try Xubuntu, which uses the XFCE desktop, and is fully compatible with both VMware's Unity Mode, and Virtualbox's Seamless Mode. As an added bonus, XFCE is lighter, faster, offers a better workflow, and (IMO) prettier that Unity Desktop, which I avoid like the plague.

Another option, which may be even better than using XFCE, is to use a more stable distribution that utilizes the older Gnome 2 desktop. An excellent choice for this is CentOS, which is a fully RedHat compatible distribution. It works perfectly with VMware. It is not suitable for those that want the newest, prettiest, most cutting edge software (i.e. Pipelight, newer versions of LibreOffice, etc...) but if you want a rock solid development, programming platform that is VERY bug free it would work very well.

Last thought, Linux Mint's MATE desktop is simply a Gnome 2 fork, so would probably offer an excellent alternative for those who need cutting edge software and VM compatibility. It also has the advantage of being based on Ubuntu, so there would be no need to adjust to the idiosyncrasies of a new Linux distro.

Anyhow, that is altogether too much info, but it's late, and I can't sleep. I hope this was marginally helpful.

1

I never had problems with Unity Mode on Ubuntu, even with the Unity Desktop. Unfortunately, that is a moot point since VMWare just got rid of Unity for both Linux hosts and guests. This is effective on Workstation 12 and VMWare Player. Just an FYI when people upgrade either product and find Unity Mode doesn't work anymore even on XFCE.

0

A bit outdated now, but it seems like they have removed it completely for every Linux guest in Workstation 12

The following features have reached end of life in Workstation 12 Pro and have been removed:

  • Unity mode on Linux guest and host operating systems

https://pubs.vmware.com/Release_Notes/en/workstation/12pro/workstation-12-release-notes.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.