I have my personal folders to a different partition other than home, I had a series of symlinks in my home folder pointing to the folders on the other partition. This was causing multiple entries in Dash search do I modified my ~/.config/user-dirs.dirs file pointing them to the folders on the second partition.

The issue is that when I search for any one of these folders in Dash, I still get two entries, one pointing the folder and another that points to the /home/username/Documents folder. If I click on this link I get a Could not find /home/username/Documents error.

Why is this and how do I delete these entries from Dash's records?

If deleting records is not possible, is there a way to "reindex" the dash search database?

I deleted the ~/.local/share/zeitgeist folder but the problem persists.

How to I force "locate" to reindex?

  • I think re-indexing will still result in having 2 entries. Dec 11, 2012 at 18:09
  • Why is that? There are no more symlinks in my home directory.
    – To Do
    Dec 11, 2012 at 21:55

1 Answer 1


I found an answer in another similar question.

Basically the problem was the old bookmarks in Nautilus.

So the solution was to open Nautilus, Bookmarks menu, edit bookmarks and then delete all the old bookmarks (that were not showing any longer in Nautilus.)

Problem solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.