10

One thing I like for MacBooks is that they are usable within a second after opening their lid when they were on stand by.

Ubuntu always requires me to enter my password when I resume from suspend, which can be very annoying.
How can I disable this?

Related bugs
It turns out that this really is undesired behavior, and there are several bugs related to this issue.
Bug #553646 on launchpad
Bug #643036 on GNOME bugzilla

  • Same question with more solutions here. One could be marked as a duplicate. – tanius Apr 10 '19 at 18:31
7

Start gconf-editor (press ALT-F2, then type gconf-editor).

Seach down to Apps/gnome-power-manager, then click on "lock".

You have two choices : either untick "suspend", or tick "use_screensaver_settings" (of course, you'd then have to go to screensaver preferences and remove the "lock screen" option.

alt text

And :

alt text

| improve this answer | |
  • Thank you, this would be be the perfect answer! If only it would work :(. I have tried both options and neither of them works. Proof: imgur.com/w4KVj&Sl385l I would report a bug but I'm not registered on the Gnome bug tracker. – Ingo Jan 22 '11 at 12:24
  • Note that "suspend" and "hibernate" options are ignored if "screensaver" is ticked. Try playing with the values and see what happens. Certainly worked for me, so perhaps a hardware issue? – Scaine Jan 22 '11 at 13:08
  • Doesn't work for me either :\ (tested it on three different machines) – Stefano Palazzo Jan 22 '11 at 13:40
  • This works for me (so far) on : Dell Vostro V13, Toshiba U400, Dell Inspiron, couple of home-built PCs, Acer Revo Ion and a few friends laptops I've built - mostly Toshiba's and Dell's who's models I forget. I can't understand why this isn't working for people. – Scaine Jan 22 '11 at 13:56
  • 1
    Yes it is really weired. This bug on launchpad might relate to it bugs.launchpad.net/gnome-power/+bug/553646. I am marking the question as answered as it is indeed the correct procedure, although it might not work on some machines. – Ingo Feb 6 '11 at 14:22
5

This will disable the locking, altogether, so you won't be able to lock the screen even if you wish to, but if you don't care, just enter this command:

gsettings set org.gnome.desktop.lockdown disable-lock-screen 'true'

regards,

| improve this answer | |
2

As mentioned in the comments, the solution mentioned above doens't work for Ubuntu 11.10. Please see How do I stop the screen from being locked on suspend? to 'fix' the issue on 11.10.

| improve this answer | |
1

Here is a solution for Ubuntu / Lubuntu / Xubuntu 18.10.

First let's switch away from light-locker and xscreensaver to the default gnome-screensaver as used in Ubuntu:

sudo apt remove light-locker
sudo apt remove xscreensaver xscreensaver-data
sudo apt install gnome-screensaver

Now for gnome-screensaver, there is a nice setting to disable lock on suspend that is permanently configured this way:

gsettings set org.gnome.desktop.screensaver ubuntu-lock-on-suspend false

To see the other possible settings for gnome-screensaver:

gsettings list-keys org.gnome.desktop.screensaver

Finally, log out from the X11 session and log in again to make the changes effective. The computer will now be usable within a second after resuming from suspend. Great to save energy in my off-grid home in winter :-)

| improve this answer | |
  • Thank you, works with my Ubuntu 18.04. – markhor Apr 4 '19 at 8:44
0

There is more work to do, beyond unticking “use screensaver settings”.

See Advanced preferences for GNOME Power Manager

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.