I am trying to install a Brother MfCJ6510DW printer on Ubuntu 12.04. I have tried various ways, but nothing woks for me. I have downloaded the drivers from the solutions brother.com

I tried to install from the "System setting- printing" on the pull-down menu. There I get the message "failed to read PPL file - it says something about a missing Asterisk in colum1 Line 1

In the terminal I get the message cannot find file or directory.

Under localhost:631/printer, I get the message " no such file or directory"

I tried to install the file I downloaded from the Brothers Solution Center on the Ubuntu Software Centre, there I get the message " The package is of bad quality"


I downloaded Mfcj6510dwlpr-3.0.0-1.i386.deb and mfcj6510dwcupswrapper-3.0.0-1.i386 I also downloaded linux-bprinter-installer-1.0.0-1.gz, but this does not help either.


The Gdebi package installed should be enabled by default on your system. If not, go to the synaptic package manager and install it. Search for 'gdebi' and mark for installation or reinstallation then complete the process.

Next, since you have downloaded the correct .deb files required IE: LPR driver and cupswrapper driver from HERE it should be straight forward.

Right click on the downloaded file(s) and install using Gdebi. If all the dependencies are satisfied it will install to the proper location(s).

In your browser you should be able to type localhost:631 and enable the CUPS printer from there. Find printer drivers, add printers and classes from the Administrator tab.

  • I followed your instructions and the printer worked right away. Thank You! – Gelterfinger Dec 11 '12 at 1:48
  • glad to help out – Ringtail Dec 11 '12 at 3:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.