After installing the proprietary Nvidia drivers, my mouse cursor looks like this:

Large mouse pointer

The arrow image is much larger than normal. How can I fix it?


  • How I installed the Nvidia drivers:

    1. Install linux-source, linux-headers-generic, and nvidia-current-updates, then reboot.
    2. Run sudo nvidia-xconfig.
    3. Run gksudo nvidia-settings, adjust the absolute position of my two monitors, and save the automatically generated xorg.conf.
    4. Apply the workaround for bug #1057000 to xorg.conf, then reboot.
  • The cursor size settings referred to in this answer are normal.

  • The problem does not happen when the mouse pointer is over Amarok or Firefox.

closed as too localized by ændrük, Luis Alvarado Apr 11 '13 at 20:35

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

  • I did a fresh installation of Ubuntu 13.04 for other reasons and can't reproduce this anymore. – ændrük Apr 11 '13 at 20:19
  • I have this problem. – Greg Nov 10 '13 at 13:02
  • @Greg Go ahead and open a new question with the details of your setup, and just be sure to link to this one. – ændrük Nov 10 '13 at 20:18
  • Same problem with amd drivers.. Fix below does not work. – Christophe De Troyer May 5 '15 at 8:29
  • for me, i got huge cursor in ubuntu after a reboot using open source drivers (intel) and i fixed it by editing ~/.Xresources or ~/.Xdefaults and adding this line : Xcursor.size: 12 and then execute xrdb ~/.Xresources (or ~/.Xdefaults). New application should be fixed, to apply to all, restart X – higuita Aug 5 '16 at 8:57

I got the same problem and in the end, I just switched from lightdm to gdm and that fixed it.

sudo dpkg-reconfigure gdm

then reboot.

  • I too had this problem and a sudo dpkg-reconfigure lightdm then log out and in fixed it for me. – codeape Feb 21 '13 at 14:59
  • 1
    I don't think this problem really justifies switching to a nonstandard display manager. Also, @codeape, that should be posted as a separate answer. And no, it didn't resolve the problem for me. – ændrük Apr 11 '13 at 20:22
  • I had this issue in Debian 8.5 and switching to gdm3 worked. – Dax Kieran Jun 26 '16 at 12:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.