I have a Printer (Brother HL-2035) attached to an Ubuntu server (latest version) via USB and shared via Samba/CUPS. On my clients (Win7) I can print from Word, etc., this just works fine.

The only thing, not working is printing PDF files from Acrobat Reader. The print dialog shows correctly on the Win7 clients and printing finishes without errors, but the printer doesnt print any page and doesnt report any error.

The cups print queue even does not list the PDF printing job, whilst listing other jobs from other applications.

I already tried to set up a "RAW" printer in CUPS... same symptoms.

Anybody with a solution?

  • 1
    askubuntu.com/questions/110727/… The last idea on this thread, using cups via http://... solved the exact same problem for me on an hp printer. – user128485 Feb 4 '13 at 12:42
  • @user128485 This is so the answer, thanks for pointing it out :) – Tobias Kienzler Apr 27 '14 at 10:05

I have noticed the same issue when trying to print from Acrobat PDF viewer from Windows 7, using my Debian Wheezy running as Printer Server with CUPS in a RK3188 Android TV Stick and my usb printer Canon MP252 connected in the usb port of that TV Stick.

The solution is to print from inside pdf viewer from Chrome i.e. then prints without a hitch.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.