I'm using 11.04 (I know that support has been dropped) 32bit on my Desktop machine.

I never had performance problems with Adobe Flash on Ubuntu. But since today, all flash videos in browsers are insanely jerky so that I can't enjoy watching them. CPU usage is at about 20%.

I really don't know what happened. The only thing changed since it worked last time was that I plugged my TV as a second monitor on my graphics card and mirrored the screen. I have an Nvidia GTX 560Ti and use the driver version 173.

I tried both Firefox and Chromium, with both flashplayer-installer and adobe-flashplugin - none of them worked. https://www.adobe.com/software/flash/about/ tells me that I have flash version It's strange that they say that should be available, but I think this is an update issue of my outdated Ubuntu version (11.04).

If I could at least find out what the bottleneck is... CPU usage is very low as already said, it also isn't a buffering issue (HTML5 plays very well by the way). I don't know how to get the GPU usage, however, the Nvidia GUI reports no increasing temperature.

Do you have any idea what is causing this issue?


The issue is probably the TV, as now the graphics card has to duplicate it's effort to display to both screens, instead of only one. I'd recommend first unplugging your TV and see if it's faster. If it isn't, then it's another issue, so try updating your driver, like so:

sudo apt-get update  # Update apt sources
sudo apt-get dist-upgrade  # Run system updates
sudo apt-get purge nvidia-*  # Remove legacy NVidia drivers
sudo apt-get install nvidia-current  # Install newer NVidia drivers
sudo nvidia-xconfig  # Write NVidia configuration to X11
sudo reboot  # Reboot your computer

EDIT: If the technique above doesn't work, try installing Google Chrome and see if the newer flash version (11.5) works better. If it does, and if you don't want to always use Google Chrome, there is a nice tutorial here that enables you to install the PPAPI version of flash (11.5) in Chromium. Firefox cannot handle PPAPI though, so it only works in Chromium.

| improve this answer | |
  • I already unplugged the TV. I have just written that I had it plugged in, since this is the only possible explanation thing I can think of. Thank you, I try to update the NVidia driver, let's see if this helps... – leemes Dec 9 '12 at 19:59
  • @leemes, I see... if it doesn't work, see my updated post, I added another method. – MiJyn Dec 9 '12 at 20:03
  • Ok the driver doesn't seem to be a problem. I also tried version 310 from the NVidia website. Trying Chrome now... – leemes Dec 9 '12 at 20:35
  • Flash player 11.5 (pepper) works. I think I'll stick to Chrome/Chromium for Flash webpages + use Youtube in HTML5 version until I have time to move to a modern Ubuntu version. ;) Thanks for your help! – leemes Dec 9 '12 at 20:38
  • @leemes, Glad I was able to help :D – MiJyn Dec 9 '12 at 20:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.