0

This question already has an answer here:

Possible Duplicate:
How to Install Broadcom / STA Wireless card (BCM43XX)

My previous question about this issue had been closed, and I had been directed to this link. I read through it all day, but none of the solutions over there helped. I still can't even switch the wireless adapter on. The only working wireless module is Bluetooth. I know for a fact that the wireless adapter is not faulty, because after having asked this question, I installed Windows and it worked flawlessly. I just decided to give Ubuntu another shot.

Here's the story: on my Dell Inspiron N4050, I upgraded from the preinstalled 10.10 to 11.04 then 11.10. Then I installed the proprietary driver through Additional Drivers. Since then, the wireless card just stopped working completely, and won't even switch on. Not even a clean, fresh installation of 12.04 fixed it.

So what now? Should I take it in for warranty replacement?

Here's the relevant output of lspci:

09:00.0 Network controller: Broadcom Corporation Device 4365 (rev 01)

marked as duplicate by Luis Alvarado, Panther, Takkat, Seth, Eric Carvalho Feb 6 '13 at 1:46

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Start by typing lspci in a terminal, identify your wireless card and edit your question with this information. – To Do Dec 9 '12 at 16:37
  • Please post the output of sudo rfkill list. – gertvdijk Dec 28 '12 at 14:21
  • The answer by jasmine.aura to this question (askubuntu.com/questions/178352/…) may help. – user2405 Feb 5 '13 at 23:18
0

What's your kernel version?

Type: uname -r. If it's 3.2 something try to install this package.

If it's not 3.2 or it doesn't work, please take a look at this.

To do things the safe way , here's the package author site, among with it's source and compiled deb.

  • Please clarify why to link to an external .deb file on a Dropbox location. Sounds suspicious to me. – gertvdijk Dec 28 '12 at 14:24
  • It was linked in the other question, the second link i posted. They said the wifi worked with this package. – ThiagoPonte Dec 28 '12 at 17:18
  • Use common sense. Don't install random packages from untrusted sources. – gertvdijk Dec 28 '12 at 17:33
  • I did a search here on askubuntu, and that solution showed up. I didn't thought of security risks. Thanks for the warning! Added a link with the source of the deb file. – ThiagoPonte Dec 28 '12 at 17:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.