I have a brand new HP Pavilion-G6 which boots to pre-loaded Windows8 and I want to change the machine to boot up into Ubuntu 12.10 whist retaining Windows 8. I am having difficulty booting into Ubuntu - I have done the following.

  • Downloaded 12.10 (64 bit) from Ubuntu site and burnt it to DVD.
  • Run the DVD from within Windows (failed to reboot the machine)
  • Installed the Boot Assistant from the DVD which allows a boot up offering Ubuntu 12.10.
  • Rebooted laptop (both with DVD in and out of the machine) selected Ubuntu option
  • Always get the same result - Black screen with white text saying C: Ubuntu\winboot\wubildr.mbr file not found. I have checked in Windows and the file does exist.
  • Researched the forums and seen various forums for answers.
  • I noticed recommendations to reconfigure BIOS to disable Secure Boot and select 'Legacy' boot up mode. I'd love to do this but HP have loaded their own 'Boot up management software' as the BIOS editor with no such options provided (at least I've not seen anything that looks 'safe' to click).

Surely life should not be this hard - and I cannot be the only one with problems?

Has anyone out there actually achieved an Ubuntu 12.10/Windows8 boot up on a Pavilion G-6 laptop pre-installed with Windows8? If so, how do you do it please?

  • Are you wanting to install WUBI or native Ubuntu? Their installation processes are very different. Dec 9, 2012 at 16:09
  • I'm after the simplest way to get 12.10 on the machine as a non-technical person - so preferably WUBI. But just to make it clear - the end result should be booting up the machine and going into 12.10 by default without opening Windows at all. Thanks for helping me.
    – Morris
    Dec 9, 2012 at 17:08
  • @Rod Smith has given a good reply. WUBI is great for experimenting with Ubuntu, but many people find it not a good long-term solution. I don't know how well WUBI has been tested with UEFI. Dec 10, 2012 at 10:10

2 Answers 2


The last I heard, WUBI didn't work well on UEFI installations; however, I don't follow WUBI very closely, so that may not be accurate. If it is accurate, your best bet is to ignore any WUBI-style boot options and instead boot the Ubuntu CD/DVD directly using the firmware's boot manager (usually accessed by hitting a function key soon after you power on). You may see two CD/DVD device entries in the list; be sure to select the one that's marked as being for "EFI" or "UEFI" and not one that's marked as "BIOS" or "Legacy." Once the installer is booted, I recommend dropping to a shell and checking for the presence of a directory called /sys/firmware/efi. If it's present, you've booted into EFI mode; if not, you've probably accidentally booted into BIOS/legacy mode. Do not proceed with installation in BIOS/legacy mode. Although you can get it to work this way, you'll need to jump through some extra hoops, so it's better to go back and at least try to get the installer started in EFI mode.

Ubuntu 12.10 does support Secure Boot, but this is a brand-new feature and so it may yet be buggy on some systems. If you want to eliminate Secure Boot as a possible source of trouble, you can certainly disable it using your firmware setup utility, but the details of how to do so vary from one system to another.

FWIW, part of the problem with UEFI systems right now is that, despite a strict and detailed UEFI standard, manufacturers are introducing their own unique bugs, quirks, and idiosyncratic ways of doing things. It's like a cross between the Wild West and the Soviet Union. The point of this is: If you get a computer and it's giving you too much grief getting the Ubuntu installer to boot, return it, and make it very clear why you've done so. You might end up with something a little less mind-bendingly dysfunctional. FWIW, I've seen more problem reports about Sony and HP machines than most others, but I don't know if that's because they're worse than others or because they're more popular than others.

  • @ Rod I have tried what you have suggested but have failed. Just so that we all know what I'm using here, the burned DVD is Ubuntu12.10 "Quantal Quetzal" Release i38C#. In windows I see the following directories: .disk ; boot; capser; dists; install; isolinux; pics; pool; presed and the following files: autorun ; md5sum; Readme.diskdefins; Wubi . What concerns me is that I do not see any sys directory. Am I using the right disk? Whatever I try, the BIOS ignores the DVD and boots straight to Windows.
    – Morris
    Dec 10, 2012 at 22:12
  • @ Rod For further information BIOS {Insyde F.12} settings: CD-Rom boot ENABLED; Legacy Support DISABLED; Secureboot ENABLED; UEFI boot order INternal DVD>USB>DVD>OS Boot Manager>USB Diskette>Network Adapter
    – Morris
    Dec 10, 2012 at 22:32
  • The files visible in a CD or DVD are largely irrelevant for booting, since CD/DVD booting is done via El Torito, which hides the files in a separate filesystem. I recommend disabling Secure Boot, since it's possible that's interfering with your boot. If that doesn't work, try creating a bootable USB flash drive; maybe that will work better for you.
    – Rod Smith
    Dec 11, 2012 at 1:49
  • @ Rod Thank you for your continuing support.There is progress. The DVD won't boot irrespective of Secure Boot BIOS status. I created a bootable USB flash drive, rebooted and pressed ESC/F9. GRUB 2.00 appeared. I selected 'Install Ubuntu'. The flash drive flashed, the screen went black and I heard the Ubuntu drums(music to my ears). But then the screen stayed black. When I tried the check disk option in GRUB that went black too. I feel we are close. Have you any suggestions please? I can almost smell success. BTW - is it worth trying WUBI again from the flash drive? What do you think?
    – Morris
    Dec 11, 2012 at 21:06
  • @ Rod It's a fix - I think? I really don't understand what happened but after the black screen I booted to Windows and then rebooted to GRUB. This time I selected demo mode and the screen came to life with that wonderful Ubuntu pattern of moving dots. Having checked that the wireless adaptor picks up my WiFi (thank goodness for that) I exited, rebooted to GRUB and selected the Install option. It's doing its thing right now. :-) Once the installation is complete, I shall post another comment to let you know the result.
    – Morris
    Dec 11, 2012 at 22:11

This appears to be the same method I came up with independently to boot my HP DV7 Envy (essentially the same build as a DV7 Pavillion). Here's a cut and paste I've been posting of what I came up with (trying to spread the work to other hapless HP owners ou there :))

For your reference, this is how I achieved dual boot with vendor (HP) installed Windows 8 / Ubuntu 12.10 on the machine that’s in the linked data sheet, with manufacturing date 08/12:


The chipset=HM77, Mobo=HP C181

In UEFI (F10 menu): • •Disable Secure Boot. I could not achieve boot in any configuration with it on. • •UEFI boot scheme (not Legacy BIOS). I tried Legacy mode, and can boot from disk, but not from an installation on the hard drive. UEFI flies right by it during boot every way I tried with it on. In Ubuntu: • •/Boot=EFI, /=EXT4, /Home=EXT4, SWAP=swap.

With this configuration I can boot with user intervention during the boot sequence: 1) During the boot sequence, select F9 to obtain Boot options in UEFI (BIOS) 2) In UEFI / BIOS, select the available Ubuntu Linux 2.6.32-21 option and proceed. 3) Ubuntu GRUB boot option screen is now available. Select preferred option and proceed. 4) I'm in.

  • Sorry for the delay in responding. I'm glad you've got it working. I hope this item has helped a few folks out there with HP laptop Christmas presents to have a slightly better 'holiday' than would otherwise have been the case.
    – Morris
    Dec 31, 2012 at 17:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .