After some partition shuffling, I've got a problem on my 11.10 system. The wired ethernet interface fails to come up, although the wireless interface is working. I'm using NetworkManager. I thought this may be a problem with NetworkManager, so I checked the config files, which look ok. I then tried re-installing the package, but this didn't resolve the issues. I'm not sure at this point if the problem is due to software configuration, or a hardware problem. I've also tried the cable in other router ports, but same problem.

The symptoms are:-

System settings -> Network reports that the cable is unplugged (it isn't)

ifconfig reports the following

eth0      Link encap:Ethernet  HWaddr f0:4d:a2:a2:a7:fe  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:10 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:792 (792.0 B)  TX bytes:0 (0.0 B)
          Interrupt:46 Base address:0xe000

My /etc/network/interfaces file has the following:

auto lo
iface lo inet loopback

My /etc/resolv.conf file has the following:

# Generated by NetworkManager

The router's red light is on for this port

dmesg reports:

ADDRCONF(NETDEV_UP): eth0: link is not ready

Probably there is a problem with the driver. First figure out which driver you are using. On my system, for example, it's the e1000e driver. I can see the name "pci:e1000e" in the listing of /sys/class/net/eth0/device/driver/module/drivers/. The driver name will appear in the module list obtained from the "lsmod" command. Search for this name in https://bugs.launchpad.net/ubuntu/+source/linux. If you don't find a bug report that describes your case then use apport-bug to open a new bug report against the "linux" package. Include the information above and make sure to say what Ethernet controller you have, as revealed by the lspci command.

  • Many thanks for this, it was a driver problem. I downloaded the official driver from the Realtek website, after looking at this page. Followed the instructions there and it solved my problem. unixblogger.wordpress.com/2011/10/18/… Thanks once again! – Andrew Fielden Dec 9 '12 at 12:22
  • Also note that after a kernel update, you will have to follow the above procedure to insert the driver module into the kernel. – Andrew Fielden Dec 24 '12 at 13:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.