I have Ubuntu10.10 x64 and after installing Windows 7 grub dissapear I log on with my usb to reinstall grub and now grub only shows Ubuntu... Then when I try to do update-grub2 I get this:

root@Alienware:~# sudo update-grub2
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-2.6.35-22-generic
Found initrd image: /boot/initrd.img-2.6.35-22-generic
Found memtest86+ image: /boot/memtest86+.bin
ls: no se puede acceder a /var/lib/os-prober/mount/boot
Boot: No existe el fichero o el directorio

It is in spanish but it says it cant get access to /var/lib/os-prober/mount/boot and that Boot: dosent exist.. I dont know what I am doing wrong can someone help me please?


This was most likely caused by you accidentally installing grub to your Windows filesystem, meaning that your Windows filesystem now contains a directory "/Boot/" created by Windows for its bootloader, and a directory "/boot/" (Note that one has a capital 'B' ant the other a lowercase 'b') created by grub-install. This is confusing os-prober. The solution is to mount your Windows partition and remove the "/boot" directory created by grub-install (To be safe, before removing it completely you should rename it to something like "bad_boot" so that you can restore it if needed rather than deleting it completely).

If you don't know how to do what I've explained above please run boot info script and post the RESULTS.txt as explained here: http://ubuntuforums.org/showthread.php?t=1291280 and I will give you step by step directions based on your current setup.


Well, I have a problem like this, I don't know the cause of yours, but in my case was about a bat partition...

So, I've tried this:

NOTE: I have windows 7 but I've tried exactly this and worked well

  1. Create a new file with necessary data:

sudo /etc/grub.d/20_windows_xp

  1. Paste in this

NOTE: Sorry, I've wanted to paste the code here, but some characters important doesn't show fine

  1. Finally, give it some execution permissions and update grub

    sudo chmod +x /etc/grub.d/20_windows_xp

    sudo update-grub

I repeat, I have Windows 7 with Lucid Lynx in one of my PC and I've made this, step by step and works fine. If you want, you can change the OS Name in the content of the file.

Hope It helps and work for you. Regards!

  • While this may allow you to access Windows again it does not fix the root cause of the error (having both a "/Boot" and a "/boot" in the Windows System partition). – Jordan Uggla Mar 15 '11 at 21:57

Not sure if if it's an unrelated issue, but it seems that something happened with the NTFS packages recently, which seems to prevent os-prober from finding some Windows partitions.

Try to uninstall the packages with a name containing ntfs and running sudo os-prober again. If it works, run update-grub2 (as it uses os-prober). You should be able to re-install the NTFS packages after this, although you might have to do this again next time you need to upgrade Grub (e.g. next time there's a kernel update).

EDIT: It looks like there's a wider issue with libfuse and ntfs-3g. (When fuse/ntfs-3g isn't used, mounting NTFS volumes falls back to using the kernel driver, which is read-only as far as I remember, but sufficient to determine the type of OS installed.) More details here:


are you using liveCD to update the grub2. if not try to reinstall grub2 via liveCD if yes then try to use windows CD/DVD to make windows bootloader install again and you will not be able to run ubuntu after that see this page

I hope that help

  • I am only able to enter linux now and grub2 seems that cannot find Windows but I cant find the reason why... – Moz Jan 22 '11 at 6:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.