I have a Brother MFC-7420, which also works as a scanner. I have attached this machine to a computer running Ubuntu 12.04 LTS 64bit via USB.

I installed the following package:


Now when I start xsane, the device is detected. However, when I try to scan or run a preview scan, I get the message Could not start scanner: Invalid Argument. The same problem exists if I run xsane as root, so I don't think it's a privilege problem.

There's no output on the console while running xsane (see screenshot below). The dialog box showing the error appeared just after pressing the "scan" button in xsane. Sreenshot showing the error

What can I do to get this scanner running?

  • 2
    xsane appears to be invoking sane with bad syntax. To be sure, can you post a screenshot showing the error? If that is what's happening, it should be reported as a bug, probably in xsane. (This question also has some good information about bug reporting.) In addition to a screenshot, please run xsane in a Terminal window (Ctrl+Alt+T) and give all the text in the Terminal; please also specify what messages appeared when. Please edit your question to provide all this info. – Eliah Kagan Jan 14 '13 at 20:43
  • I've added the information you requested. – Bob Jan 15 '13 at 10:36

I had the same problem and fixed it by editing /lib/udev/rules.d/40-libsane.rules.

I uncommented the line:

ENV{DEVTYPE}=="usb_device", MODE="0664", OWNER="root", GROUP="root"

Then edited it to be:

ENV{DEVTYPE}=="usb_device", MODE="0664", OWNER="root", GROUP="saned"

After that I added my user to the saned group. It all works now.

The problem is that it wants to run as root till you do this.

| improve this answer | |

If none of the above work, what worked for me was to go to the brother site. The issue is that - at least with Brscan2 x64 - that the drivers are installed to the wrong directory. go to Brother sacanner Faq if you look @ the section: that says

I'm using Ubuntu 11.10 or higher. I cannot scan from my Brother Machine.

the instructions say to copy some files - that was what ultimately solved it for me. I expected that when I installed the Brother linux drivers, that was it. But no, the drivers installed to directories that my version of ubuntu (linux mint Nadia Xfce x64) doesn't use. So copying those files over immediately solved it.

| improve this answer | |
  • didn't work for me, I had to emulate android and use the android app instead. – virtualxtc Dec 28 '13 at 8:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.