9

I am using LibreOffice installed on my Linux box and I seem to be having a weird problem in that the conversion seems to be taking place, and there seem to be no errors, but there is no output file in the specified output directory.

Here is an example of the command I am using:

/opt/libreoffice3.6/program/soffice --headless --invisible --convert-to pdf /dir/file.pptx --outdir /dir

And here is the result of that command:

convert /dir/file.pptx -> /dir/file.pdf using impress_pdf_Export

But the problem is that after running the conversion /dir/file.pdf does not exist.

I tried a doc file and the command worked, and saved properly. Even though the conversion seems to be taking place with the pptx file, it does not seem to save it anywhere, oddly.

Do any of you have any suggestions?

  • 3
    Ubuntu 14.04 - the same problem happened to me. Turned out, the conversion from command line doesn't work at all if there is already GUI version of LibreOffice running. – Dummy00001 Jun 1 '15 at 9:55
3

I use this command and it work properly:

libreoffice --headless --invisible --convert-to pdf --outdir ~/dir  ~/dir/file_to_convert.pptx

But if you can convert a .doc file, you should be able to do the same with .pptx file. It's odd...

| improve this answer | |
2

As noted in a comment to OP, it is vital that no instance of LibreOffice is running.

When I was attempting to do a soffice conversion, I hadn't run LibO at all, so I thought this wasn't my problem. However, on checking Task Manager, it showed "soffice quick-start" running, and this was preventing the conversion.

So it seems this old bug is still present in latest LibO (I'm running v. 5.1.1.2 under Ubuntu 14.04 LTS), and it's worth being aware of it given the silent "quick-start" instance of soffice.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.