I'd like to install Ubuntu on a pavilion g6 2255 but unfortunately the computer enters an endless loop during boot. What I observe is:

  1. the screen is switched off
  2. a few seconds later, the screen is switched on but remains blank and dark
  3. repeat from step 1

I reproduced these steps with Ubuntu 12.10 and 12.04 both in 32 and 64 bits either from a CD or a usb key. I also tried to boot from a live usb key with the same results. My usb key works fine as I can boot from it with another computer.

What can I do to overcome this bootloop? I read about setting modset=0 in the boot config file, in order to circumvent the lack of drivers for some recent graphical cards, but I'm not certain that would resolve my boot loop problem


As asked in the comment beneath, no text gets printed during the process I described. Actually I don't even believe this problem is related to Ubuntu since when I press escape during step 2, I can almost access the computer boot/bios menu. But the computer "runs short of time" and reboots.

In order to check if it was Ubuntu related my plan was to boot from some other USB-based unix both with my old computer (that actually boots Ubuntu) and with my new HP pavilion g6 2255, then compare. As I have installed OSX mountain lion on my old Mac today (a third computer) via USB, I decided to use it as a test specimen. Here are the results :

  • Old PC : nothing, just an underscore prompt blinking on the screen (which was to be expected since it is amd-based).
  • HP pavilion : the boot loop I described above

On this basis, I decided it wasn't Ubuntu related and tried to toggle the settings that seemed relevant in the bios, one by one. I first changed the way USB behaves during boot and set the computer to recognize USB as 2.0 during pre-os stage then enable USB 3.0 afterwards. The boot loop was still there.

Then I enabled legacy support which is useful for some "old" OS then booted on the osx dongle. I observed the same blank but switched-on screen as in step 2 but without the loop.

That's when I decided to try to boot from a Ubuntu install disc, with the hope that I had overcome the boot loop problem and that now osx was the problem (which is probably to be expected since this is a 100% legit osx version, not something to build hackintoshes).

And that's when I got that epic result : after having inserted the disc and forced the computer to reboot it turned out I'm not even able to switch my computer on anymore. I press the power button and absolutely nothing happens, just like if I was trying to power on a brick.

So I guess I solved the problem from above but I think I need some more help (I'm actually laughing as I write this) : I will return this god forsaken time abyss PC to the store.

Is it legit/legal/allowed/in the scope of my warranty to do what I have done? I mean trying to boot on a osx USB stick with no intent of installing it whatsoever? How should I act? Tell them the truth or act like a fool that just wanted to install Ubuntu on his laptop?

  • Do you see any text before the problem starts? – To Do Dec 6 '12 at 22:00

I'd have to say that you should be fine. But maybe avoid mentioning that you tried to boot OSX. All you have attempted to do is boot your computer to a Unix based operating system from an Optical and Solid state disk, failed to actually modify your configuration, and ended up with a non-functional computer. You've done nothing that should cause a problem. The reboot loop does seem to be a common issue on HP laptops, my HP Envy is doing the same when I try and boot to an Ubuntu flash drive.

| improve this answer | |

If you get a BIOS boot loop on an HP device, you may have to set the device to manually boot via an EFI file called Grub on your Ubuntu installation. HP secure boot seems to ignore Ubuntu EFI files, unless you manually specify them. You can first test that you can boot by going into the HP OS Boot Manager (Pressing ESC once during boot loop) and selecting Ubuntu.

If that works, and you want to have this be the default, you'll need to prioritise "Custom Boot" in the boot priorirty list as the first option, and then manually type out the EFI path as follows:


^ This cryptic path can be found via the Boot via EFI File menu option, in case it differs for your device.

EDIT: This answer explains it in more detail: https://askubuntu.com/a/624964/114641

| improve this answer | |

Im not sure if this is the problem you are having but I have more than ones experienced that my usb3 flash drive that can install windows or macOS, does not work with linux even on the same computer. The installation starts but crashes during installation. The solution for me was to use a USB2 flashdrive instead.

| improve this answer | |

My G6 did the same thing. To turn the computer back on, just keep holding the power button. It worked for me at least when I was trying to install Windows 7. Good luck!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.