19

I have a .mp4 movie (it's an .mp4 file, and the "video codec" is Xvid, and the "audio codec" is mp3) that I want to play, but when I try to open it in MPlayer, it says "The steam is encrypted and decryption is not supported." I tried to apply the answer from this question and this wiki page, but neither worked.

Any suggestions?

The file came from an [apparently] less than reputable site, which I guess I can't link to. :(

I've tried:

sudo apt-get install ubuntu-restricted-extras
sudo apt-get install libdvdread4
sudo /usr/share/doc/libdvdread4/install-css.sh
sudo apt-get install gstreamer0.10-ffmpeg
sudo apt-get install w64codecs
sudo apt-get update
7
  • can xine or VLC play the file? Jan 21 '11 at 15:35
  • 1
    xine gives a similiar error message, and VLC plays a scrambled mess of random colors for 6 seconds.
    – Andrew
    Jan 21 '11 at 15:43
  • Is ubuntu-restricted-extras installed? (update your question with everything you've tried as you continue to work on it) Jan 21 '11 at 16:33
  • 8
    +1 for posting a torrent link on a stack exchange site! lol Jan 21 '11 at 16:50
  • 1
    Hi, I've had a similar experience. That file may be corrupt or not what it's "pretending" to be. Careful running that on Windows since the last time I encountered a similar video file that VLC, Mplayer, Totem, including WMP, couldnt' play, it was actually a malware of sorts. Yes, so much for downloading from sites with questionable repute.
    – Marky
    Jun 2 '11 at 5:02
19

In a terminal, type in sudo apt-get install vlc, press enter, and key in your password when prompted.

VLC Player will play just about anything. If your MP3/MP4 files still do not work, you will need to download the restricted codecs pack. Search for these in Google and use the above command to install them once you find out what the file-name is. I.e., type in sudo apt-get install [filename].

DVD playback is the same as above, you will need the restricted repositories. Again, once you locate them, just type in the above.

EDIT: All of the above, and indeed many other countless codecs and programs can also be installed through the Synaptic Package Manager. To access this, click Systems > Administration > Synaptic Package Manager.

This can be a bit of a headache though, as there are many, many things available, and if you do not know the specific program name or keywords for it used through the search function, it can be difficult.

2
  • 1
    It's not necessary to start a root shell first, if you're going to run administration commands as root with sudo. You can skip sudo -s, and just use sudo apt-get install vlc. Please note that it's best to run sudo apt-get update first as this updates local information about what packages are available from where in what versions. This can prevent a variety of installation errors (including some "unmet dependencies" errors), and also ensures you get the latest version provided by your enabled software sources. Mar 21 '13 at 12:21
  • No it will not but dragging the file into Firefox plays it.
    – NoBugs
    Jan 17 at 4:23
2

My solution was to go to Tools > Preferences > Video, make sure Enable video and Window decorations were checked, then set the Output drop-down menu to X11 video output (XCB).

See this answer for more information.

1

Try xine or VNC media players, My personal choice is xine because it uses very little resources. Both are in the repository. Edit, sorry, did not see comment above. Where did the file come from? Can you post a link to it? Is it a pay to view movie?

2
  • It's not exactly pay-to-view, and I don't think I can post a link to it.
    – Andrew
    Jan 21 '11 at 17:06
  • 1
    Do you really mean VNC media player? If so, is there a link? Or should that be VLC? Oct 12 at 16:08
1

It's probably protected by DRM (Digital Rights Management). Quite a number of the songs and such are DRM protected if the origical source is from iTunes etc.

The answers given here possibly applies to you as well.

0

I uses either VLC or SMPlayer, but you need to have all the correct codec, for your issue of the error messages, there are many threads around but perhaps you could scan thru each of those

http://www.google.com/search?client=ubuntu&channel=fs&q=mp4+video+The+stream+is+encrypted+and+decryption+is+not+supported.&ie=utf-8&oe=utf-8

0

Install Totem, the default GNOME video player:

sudo apt-get install totem
0

Dragging and dropping the file in Chrome/Chromium browser also works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.