I have a new HP Envy dv6 7200 with dual boot Windows 8 / Ubuntu 12.04. In windows, the F12 key in Windows activates the "airplane mode" switch which enables/disables both on-board (mini PCIe) and USB wireless adapters. In Ubuntu, however, the wireless adapter is turned off by default and cannot be turned back on via the F12 key (or any other combination of F12 and Ctrl, Fn, Shift, etc.).

Let me explain the "fixes" I've seen in various forums and explain what did or did not happen. These are listed in no particular order. (Spoiler alert: wireless is still broke).

Solution 1? Use HP's "Wireless Assistant" utility to permanently activate the wireless card in Windows, then boot into Ubuntu to happily find it working.

Unfortunately, this utility works in Windows 7 but not Windows 8. On the other hand, hardware drivers from HP are only available for Windows 8 for this model. Catch 22 (I could not find a comparable utility for Windows 8).

Solution 2? Use a USB wireless adapter to sidestep the on-board device.

I purchased such a device from thinkpenguin.com to be sure that it would be Linux-friendly. However, the wireless switch enables / disables all wireless devices including USB. So, there's my $50 donation to the nice folks at thinkpenguin.com, but still no solution.

Solution 3? Following the Think Penguin folk's suggestion, modify the mini PCI express adapter following instructions here: http://www.notebookforums.com/t/225429/broken-wireless-hardware-switch-fix

Tempting, but I then violate the terms of my warranty mere days after opening the box. This might be a good solution for an older machine that you want to get your geek on with, but not for a new box.

Solution 4? rfkill unblock all

No effect whatsoever.

ubuntu@ubuntu-hp-evny:~$ rfkill unblock all
ubuntu@ubuntu-hp-evny:~$ rfkill list all
0: hp-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

Solution 5? Re-install drivers.

Done and done. Ubuntu recognizes the device - perhaps even without re-installing the drivers? - but cannot turn it on. How do I know this? In the Network Manager drop-down menu, the wireless option is blacked out and a message reads something like: "wireless network is disabled by a hardware switch".

Solution 6? Identify a physical switch on the laptop and flip it.

There is no such switch on this machine. In fact, walking through Best Buy yesterday, I checked and not a single new laptop PC had a physical switch on it. All of the wireless switches are either the F2 or F12 key ... I wonder if askubuntu will not be plagued by this exact issue in the near future?

Additional info - lspci

ubuntu@ubuntu-hp-evny:~$ lspci
00:00.0 Host bridge: Intel Corporation Ivy Bridge DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Ivy Bridge PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Ivy Bridge Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation Panther Point USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation Panther Point MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation Panther Point High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 1 (rev c4)
00:1c.2 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 3 (rev c4)
00:1c.3 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 4 (rev c4)
00:1c.5 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 6 (rev c4)
00:1d.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Panther Point LPC Controller (rev 04)
00:1f.2 RAID bus controller: Intel Corporation 82801 Mobile SATA Controller [RAID mode] (rev 04)
00:1f.3 SMBus: Intel Corporation Panther Point SMBus Controller (rev 04)
01:00.0 VGA compatible controller: NVIDIA Corporation Device 0de9 (rev a1)
08:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5229 (rev 01)
0a:00.0 Network controller: Ralink corp. Device 539b
0b:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 07)

Any suggestions would be much appreciated!

  • I've stumbled across the certification site for Ubuntu and found your laptop in the list would you happen to have heard of it working nowadays? As it stands it would seem it now works, though don't know when this would have been changed.
    – Oyibo
    Commented Dec 25, 2012 at 10:49
  • Hmm, not sure. I had the Envy, not Pavilion. Also it appears that the hardware is only certified for pre-installed Ubuntu (mine had pre-installed Windows 8) ...
    – Dave B.
    Commented Dec 30, 2012 at 9:35
  • It may not be the exact same model, however it does have the same: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller seeing as it was causing the issue, maybe an updated driver had solved it since. Might as well leave this question open for future users with the same problem if it persists as its very complete as it is.
    – Oyibo
    Commented Dec 30, 2012 at 9:47
  • Also I've found out why the model is branded Envy/Pavilion, its because HP rebranded the Pavilion dv6 and moved it to its Envy line of laptops. However they are essentially the same (bar later models having improved specs).
    – Oyibo
    Commented Dec 30, 2012 at 10:03

2 Answers 2


I have the same problem with the DV6Z-7200 (the AMD APU / AMD discrete Video version).

Modding the Insyde BIOS is not an option - as it's UEFI, it comes encrypted and cannot be opened by the ezH20 Insyde BIOS Editor. I contacted HP Tech Support & put in a request for the BIOS department to add an option to enable the Wireless card (Linux) or disable it (windows) - if enough owners do this perhaps they will actually release a BIOS update with this fix.

I upgraded the RAM today and the wireless card is easily accessible just to the left of the RAM slots. Taping the appropriate pin (Solution 3 above) to prevent the card being disabled by the BIOS is relatively straight forward - unplug the 2 aerials & undo 2 screws to lift out the card.

Another possible solution would be a KVM virtual machine running WinXP / Win7 with the wireless card passed through to the Guest using USB Passthrough & using the "HP wireless Assistant" to turn the card on & off.

  • I hate to say it, but after several days of trying to address this problem I returned the HP. I called HP support, talked to the Think Penguin guys, and spend hours in the forums trying to find a solution, to no avail. Ultimately, I went into Best Buy with a Linux CD and found that Dell Inspiron works well out of the box. Indeed, a look at this page: ubuntu.com/certification suggests Dell might be the most hassle-free option for Ubuntu lovers (wish I had seen it earlier)! I am happy to report great success with the Inspiron 15R SE (7520) ... even the wireless button works!
    – Dave B.
    Commented Dec 22, 2012 at 7:11

I have an HP Envy dv6-7375ez laptop running dual boot Windows 8 and Ubuntu 12.04.03. The laptop comes with a Ralink 3290 wireless card. In Windows, it works fine. Airplane mode is switched on and off with the F12 key.

To get wireless to work at all in Linux, I had to upgrade the kernel to 3.6.11-030611-generic. Some people reported having problems getting this driver to work in 12.10, but I wanted to stay with 12.04 LTS anyway, so I upgraded the kernel. Details are here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1049466/ (see comment #16).

You can then follow the instructions in this link to download, build and install the Ralink 3290 native driver: Wireless driver - how to load manufacturer's STA file (Ralink 3290). I was thus able to get wireless to work if no ethernet (wired) connection was present. However, Bluetooth and wireless WLAN seemed always either both enabled or both disabled. Turning one off or on would do the same to the other. Since I really don't care about Bluetooth and would rather have it off all the time, this was less than satisfactory.

After that, I updated the BIOS in a Windows Update session, and then I was always getting the "Wireless network disabled by hardware switch" even though I had run "sudo rfkill unblock all". Blacklisting the HP driver finally did the trick (see what it is called by doing "sudo lsmod | grep hp" ... on my system it is "hp_wmi").

I can now even turn wireless on or off using the F12 key. :) However, the indicator light is always the same, and after you hit F12 it takes a few seconds to toggle (i.e. enable/disable) the wireless, so check the network menu in the status bar to see what it is at the moment. I can live with this for now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .