58

I'm using Chrome, and the scroll rate is like 3 lines, and it's painfully slow. My finger gets tired really quickly on long pages. System → Preferences → Mouse lacks any scroll wheel configuration options.

57

The fix for me for this (I had it for months) was pretty surreal and like most folks I didn't believe it until I did it:

Some MS mice have a scrollwheel bug.

Try unplugging the USB cable / dongle then plug back in.

Also, I noticed that if you have the dongle plugged in to the computer and the mouse has an on-off mechanism then you can just turn the mouse off and back on. That resets the data link between the mouse and dongle.

:)

  • 3
    Fixed it for me. My scroll rate was way too fast, not too slow, but same solution. I have a KVM switch to go between a Ubuntu machine and Windows 7. The problem returns every time I KVM back to the Ubuntu. Give the mouse USB doodad few seconds of freedom, and the problem is gone. – DarenW Sep 5 '13 at 16:58
  • 2
    I can't believe it. This fixes it for me as well. – Hery Apr 20 '14 at 13:35
  • Fixed MS Wireless Mobile Mouse 1000, FCC ID: c3k1452 model 1452 – rlib Jul 11 '14 at 15:02
  • 1
    +1 I was skeptic too, but it works. When in doubt with MS, reboot. – nha Jul 31 '14 at 20:20
  • In my case, just turning on and off my mouse worked. – lepe Aug 23 '14 at 12:22
31

I wanted to do this too, and I figure I most often want to do it in a web browser (where else do you really mouse-wheel scroll a great deal?)

For Google Chrome

One can no longer change the scroll amount with command line parameters. However, you can use this add-on extension: https://chrome.google.com/webstore/detail/chromium-wheel-smooth-scr/khpcanbeojalbkpgpmjpdkjnkfcgfkhb?utm_source=plus

For Firefox

  1. In the url field, type about:config.
  2. Search for the following settings and change their values as desired:

    mousewheel.system_scroll_override_on_root_content.enabled
    mousewheel.system_scroll_override_on_root_content.horizontal.factor
    mousewheel.system_scroll_override_on_root_content.vertical.factor
    
  • 6
    On firefox 17 and up, "mousewheel.withnokey.sysnumlines" and "mousewheel.withnokey.numlines" are both deprecated. The new settings' names is: "mousewheel.system_scroll_override_on_root_content.enabled", "mousewheel.system_scroll_override_on_root_content.horizontal.factor" and "mousewheel.system_scroll_override_on_root_content.vertical.factor". You can see it here: bitbucket.org/cat_in_136/configuration-mania/issue/101/… – Leonardo Montenegro Aug 9 '13 at 17:35
  • 1
    According to a comment below, --scroll-pixels is deprecated and may not be available for chrome anymore. in that case, see this extension: chrome.google.com/webstore/detail/chromium-wheel-smooth-scr/… – Michael Butler Jan 30 '14 at 22:46
  • 1
    For the impatient, regarding the Chromium Smooth Scroller: Settings that worked well for me (trusting you want things faster than default, too): Step Size: 100, Smoothness (forepart): 0, Smoothness: 68, Acc Sensitivity: 115 and (much further down): Bouncy Edge: 0 (irritating gimmick imho) – Frank Nocke Oct 25 '16 at 1:18
  • 1
    Why does that plugin „require“ full access rights to every web page I read? – Frank Nocke Nov 17 '16 at 9:08
7

From triaged bug #619403 on mouse-wheel acceleration against xorg-server with a link to this patch you can see there is work in progress.

In addition there is a Wiki on how to configure input devices that gives you ideas on what is possible at present:

Use xinput to show setting of your input devices:

xinput --list gives you information on your hardware xinput query-state "name of device" lists the current settings (including mouse wheel!)

Only after you know how your mouse is set up you are able to change these setting using xinput with the option appropriate for your device.

  • how do you apply this patch? – user6465 Jan 22 '11 at 0:24
  • 1
    If not for testing or contributing it is generally not a good idea to patch Xorg server. If you don't know exactly what you're doing and something goes wrong you may end up with a non-responsive system. – Takkat Jan 25 '11 at 7:15
7

The option to configure mouse wheel speed in chrome seems to have been removed, however the Chromium Wheel Smooth Scroller extension seems to work really well.

3

UPDATE:

There is a new, great extension for mouse's wheel settings in Chrome. Use it and you can customize your wheel behaviour:

https://chrome.google.com/webstore/detail/chromium-wheel-smooth-scr/khpcanbeojalbkpgpmjpdkjnkfcgfkhb?utm_source=plus

OLD:

Please note unfortunately --scroll-pixels is deprecated and removed from Chrome and Chromium. This flag has not effect on scroll speed.

More details here: https://code.google.com/p/chromium/issues/detail?id=154776

3

This was also annoying me.

This following is one option quoted verbatim from a comment here

sudo apt-get install imwheel

place the following in ~/.imwheelrc

"^google-chrome$"
None, Up, Button4, 2
None, Down, Button5, 2

(replace 2 by the number you want to multiply scrolling by)

$ imwheel
  • I added imwheel to my startup applications
  • I found the mutliplier 2 to be about right.

Update: I found that the following option actually disabled Ctrl+Scroll to zoom, which I quite like.

  • 1
    Another side-effect is that this affects all mouse wheel events, not just scrolling. E.g. if you ever use the mouse wheel to change tabs this will ruin that functionality :) – Sheldon Nov 29 '11 at 14:58
  • Have a look at this similar post: askubuntu.com/a/621140/385212, it demonstrates how to still use Ctrl+Scroll to zoom, etc. – Steven C. Howell Aug 13 '15 at 22:38
  • this doesn't seem to work any longer :( – Jeff Puckett Apr 29 '16 at 19:16
  • This worked in chrome, however any other application it now selects the text rather than scrolling the window :( – Jamie Hutber Nov 11 '16 at 12:34
  • Thanks for the startup applications advice. I was digging around „upstart“ which of course is way to early in the process... – Frank Nocke Nov 17 '16 at 9:46

protected by Community Mar 26 '15 at 18:33

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.