2

I have a Logitech MX5000 keyboard/mouse combo. I'm using the Logitech Bluetooth dongle, and I use it in USB emulation mode (not native bluetooth).

I tried to install Ubuntu 10.04 using WUBI. After the Ubuntu setup started natively, the keyboard and mouse refuse to work.

I have no other keyboards or mice around. I tried unplugging and re-plugging the USB dongle to make sure it's in USB mode and not bluetooth, but when I do that the keyboard refuses to re-pair with the dongle (using the connect buttons). Rebooting into Windows 7 and the keyboard/mouse instantly come back.

Any ideas how I can get Ubuntu 10.04 installed?

  • I had this problem on a Dell Inspiron 2650 when installing 10.10, with the internal keyboard/touchpad combo. Still having trouble with it, in fact. askubuntu.com/questions/16813/… – dgw Dec 16 '10 at 1:53
2

Unfortunately, I don't know what the problem is but I did come across this program called HIDpoint which is a configuration program for a variety of Logitech input devices (and a couple of others). I can't say if it will help with your issue, but I thought it might be worth investigating if nothing else is working.

HIDpoint's supported devices page lists a Logitech MX5000 keyboard but I don't see an MX5000 mouse there. The download page says that it supports Ubuntu 10.04 and Ubuntu 10.04 64bit.

| improve this answer | |
  • The mouse is an MX3100 (which shipped standard with the MX5000 keyboard bundle). However - how do I get it installed? I can't even install Ubuntu because of the lack of keyboard and mouse support. – Mark Henderson Aug 14 '10 at 11:26
  • @Farseeker Sorry, I misunderstood that detail. I looked on Launchpad and apparently this is a known issue, but unfortunately all the workarounds I found require a spare keyboard (which you don't have). Does it make a difference if you plug the dongle into a different USB port when you reset it? – moberley Aug 14 '10 at 12:23
  • 1
    I know it doesn't help you (because it requires another keyboard) but here is the bug workaround for 10.04 that I found bugs.launchpad.net/ubuntu/+source/bluez/+bug/318465/comments/31 – moberley Aug 14 '10 at 12:24
  • @Moberly, all good. I'll grab a spare keyboard from work on Monday and use that :) THe USB port makes no difference. – Mark Henderson Aug 14 '10 at 22:14
0

I had the same problem with this desktop around Ubuntu 8.10. The workaround was to uninstall bluez-utils (I think, or bluetooth completely). This made it work, but I eventually put it on ebay and bought a mx1000 with a standard keyboard.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.