I have installed Ubuntu 10 last night and finished all upgrading stuff, in the time when updates are applied I downloaded a torrent file. As soon as download is finished I rebooted my system. As usual at start up it asked my login and I did the same.

After a successful login It should show me the desktop, or show an error message in case anything has gone wrong. But what I had is only a cursor and a blank wall paper.

Can anybody tell me what is the problem and how to resolve this?


closed as too localized by jrg Feb 23 '12 at 15:02

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    It might help if you could possibly add the contents of /var/log/messages and /var/log/Xorg.0.log right after the event to pastebin.ubuntu.com and provide the links here to help us get some idea what is failing. – MttJocy Jan 21 '11 at 11:26
  • Ok let me say, none of the options worked, I had to reinstall everything. And its been a week since the os runs flawlessly. – Prasham Feb 4 '11 at 6:47
  • 1
    First what is Ubuntu 10 is it 11.10 or 10.10 – Black Block Nov 29 '11 at 12:46
  • 1
    Closing it as 'too localized' as the OP solved the problem by reinstalling it. – jokerdino Feb 23 '12 at 14:59
  • For anyone else who has this problem: see Unity doesn't load, no Launcher, no Dash appears – Eliah Kagan Sep 14 '13 at 5:24
  1. Press Ctrl+Alt+F1

  2. Login

  3. Type

    sudo apt-get update
    sudo apt-get install --reinstall ubuntu-desktop
    sudo reboot

Did you fill up your root-partition?

Ctrl+Shift+F2, login and issue: df -h, if that's zero for your rootdevice you'd get the symptons you describe.

It would be helpful to get some logging.

  • +1K, Muahhhh...... that did it.. root partition was 100% used... deleted some data and rebooted.. boommmm.. working.. – LaL ZaDa Sep 16 '17 at 8:49

I had (have) the same problem on a Dell D630 and NVIDIA chip and ubuntu 10.10. It only happens if i use ANY of the following:

  • NVIDIA proprietary drivers version 280 something. if i revert to 170 something, it is fine
  • If i use an updated kernel from the kernel.ubuntu.com site pass 2.39. if i use any 2.38, it works fine.

weird huh?

Try the following,

  • Boot into recovery mode (hold on shift while restarting)
  • choose to run in failsafe graphics mode for this session only.
  • Go to hardware adapters and choose the nvidia 170 something (assuming you use nvidia)
  • Go to http://kernel.ubuntu.com/~kernel-ppa/mainline/ and download the kernel files
  • To install:
    • Open command line and install the all headers file, then the headers for your architecture (x86, or x64), then the image file for your architecture, by using sudo dpkg -i filename.deb
    • OR, double click on the .deb files on the order mentioned above and install them. they should open with gDebi or ubuntu Software center, both which will allow you to install them.
  • then restart.

I hope this helps. again, just my experience, but i am not an expert by any means.

  1. Ctrl Alt F1
  2. sudo apt-get install update
  3. sudo startx

Not the answer you're looking for? Browse other questions tagged or ask your own question.