I am really a new Ubuntu user, but for some time ago, I have tried Xubuntu and I liked it. Because of this I went a little further to Ubuntu.

Right now, I am having this problem. I use internet via a 3G Modem, model HUAWEI E303C. The ISP service provided is with Movistar in Argentina.

The problem is that I can't establish a connection with the Modem. I mean, since I installed Ubuntu and configured the Broadband Mobile access, it never seems to establish a connection to it. The modem is correctly recognized however.

Because of this, I tried to reinstall 12.10 (Downloaded the ISO image), this time, before using my 3G modem, I updated the system and rebooted. Then I proceeded to connect the 3G Modem to the PC and to configure it. Went to the Network icon --> Edit Connections... --> Mobile Broadband. From there I configured the modem since the default was Movistar Argentina. The curious thing is, after saving what I configured, I went to the Network Connection icon and for the first time, I could establish a connection, but there was no internet access from the modem. I tried loading some pages and they just stayed on "loading...". I then rebooted the PC again, but this time, I haven't been able to establish the connection.

It caught my attention that Ubuntu asked me to create a report about the problem, particularly with the USB section. The thing is, after all of this, my question is:

How can I configured and establish a connection with my E303C 3G Huawei Modem in order to use the Movistar 3G Argentina Service provided in my country.

Again many thanks, I am new to this system but I actually love it, specially the terminal. I love the fact that I can use commands to configure stuff.

Really hoping that somebody can help me. Many thanks.

PS: I don't know a lot of English, this is why I used a translator, although I know is not the same.


Realmente soy novato en Ubuntu, pero hace un tiempo había probado Xubuntu y me gusto, por lo que fui un poco más alla.

Estoy teniendo este problema. Uso internet a traves de un módem 3G, cuyo modelo es HUAWEI E303C. El servicio es brindado por movistar argentina. El problema es que no puedo establecer una conexión con el mismo. O sea, desde que instalé ubuntu, configure la banda ancha móvil, nunca establece conexión, pero al modem lo reconoce.

Frente a esto, volví a reinstalar ubuntu 12.10 (es la iso que descargue), esta vez, antes de usar mi módem 3G, actualicé todo el sistema. Luego, reinicie, ahora con el módem 3G conectado. Fui a editar las conexiones, banda ancha móvil, configure mi conexión tal cual es la predeterminada para movistar Argentina. Lo curioso, es que guarde, fui a la conexión y por primera vez pudo establecerse la conexión, pero igual no andaba internet... quedaba cargando. Reinicié la máquina, y nuevamente, no he podido establecer más la conexión.

Me llamó la atención, que ubuntu me pidio de informar un problema del sistema, y particularmente era con el usb-data, o algo asi. La cuestión, es que quisiera saber de que manera puedo configurar mi módem 3G Huawei E303C para poder utilizar mi servicio de Movistar 3G Argentina.

Muchas Gracias, soy nuevo en este sistema, pero realmente me encanta... sobre todo la terminal... me encanta poder usar los comando para configurar las cosas. Espero que alguien pueda ayudarme. Muchas Gracias.

PD: No manejo bien el inglés, por lo que utilicé un traductor, aunque se que no es lo mejor.


Had tested many solutions to this problem without any success. Lately after many of looking about this i finally found the magic solution.

I called magic cuz its like windows install something and work jiji, check it out the applicacion had many countries to work already preconfigured.

It worked for me Ubuntu 12.04. liquorix kernel, Movistar Argentina. Huawei e303c.


If you use it, beware it removes modem-manager

| improve this answer | |

There is a Moviestar 3G app that I use here in UK;





I have not managed to successfully configure mobile braodband through network manager itself, the app bypasses it completely.

| improve this answer | |
  • He probado lo que me has dicho, pero sigue sin funcionar. Pude instalar el escritorio movsitar 3G, pero nunca me reconoció el mi módem. Es complicado por lo que veo, pero se que alguna solución dee haber. Sino tal vez tenga que esperar una actualización de Ubuntu. Gracias por tu ayuda! – Luciano Dec 6 '12 at 10:55

I was searching and searching the way to fix my network connection and finally i did it. It works without any command on terminal. The software is included in that version. I don't know if that "fix" works with 12.04 of later, but it's not bad idea to prove.

You must change it in dashhome>Disks

there will appear

(1) CD Drive Huawei Mass Storage

and (2) Drive Huawei SD Storage

Inside settings (edit mount options)

to you must change in (1)

mount point: /mnt/usb-HUAWEI_Mass_Storage-0:0


mount point: /dev/sr0


Identify As: /dev/disk/by-id/usb-HUAWEI_Storage-0:0

***and in (2)


mount point: /mnt/pci-0000:00:14.0-usb-0:1:1.5-scsi-0:0:0:0

identify as: /dev/disk/by-path/pci-0000:00:14.0-usb-0:1:1.5-scsi-0:0:0:0

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.