Possible Duplicate:
How to disable X at boot time?

How do I boot Ubuntu by default into the CLI using a multiuser runlevel? I wish to still maintain my graphical desktop manager (GDM or whatever replaced it) since I do use that to switch between Unity and Awesome WM. I do however wish to boot by default into a CLI login shell. I could then startx to start my GUI if I need it. I am aware that Ctrl-Alt-(F1-6) will open a separate tty instance with a login shell but it seems wasteful to have a GUI running even if asleep if I am working purely from the command line.

marked as duplicate by stephenmyall, Jorge Castro, fossfreedom Dec 6 '12 at 21:02

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.


Add text as a kernel boot parameter.

Explained in detail in this answer to a possible duplicate question "How to disable X at boot time?".

  • Not sure this is a duplicate. How to disable X at boot time?" seems to be talking about disabling it once. This seems to be asking how to have it always disabled. That said if you use this options remember to update grub. – coteyr Dec 5 '12 at 13:15
  • To make is persistent is quite straightforward. Just make your bootloader (Grub probably) use this parameter by default. And hey, it's in the answer already! GRUB_CMDLINE_LINUX_DEFAULT="text" – gertvdijk Dec 5 '12 at 13:16

This Document Should help

Basically you edit /etc/init/rc-sysinit.conf and add/change


  • Make sure the read the document, there are a couple of ways. – coteyr Dec 5 '12 at 13:04
  • Runlevel 2 isn't without X on my machine. It has been with many other distros. – user unknown Dec 6 '12 at 12:20

Not the answer you're looking for? Browse other questions tagged or ask your own question.