I was running 12.04 with Unity 3D for 6 months; my laptop ran almost silently and cool enough to hold on my lap with ~4 hours of battery life. I updated to 12.10 and switched to the Gnome 3 Shell. Now my computer gets too hot to hold on my lap, the fan is constantly running on full blast, and I have about 45 minutes of battery life. The behavior is consistent between battery power and A/C power. This is the output of sensors:

Adapter: Virtual device 
temp1:        +84.0°C  (crit = +99.0°C)

Adapter: ISA adapter
Physical id 0:  +84.0°C  (high = +86.0°C, crit = +100.0°C) 
Core 0:         +74.0°C  (high = +86.0°C, crit = +100.0°C) 
Core 1:         +72.0°C  (high = +86.0°C, crit = +100.0°C) 
Core 2:         +75.0°C  (high = +86.0°C, crit = +100.0°C) 
Core 3:         +84.0°C  (high = +86.0°C, crit = +100.0°C)

Adapter: PCI adapter 
temp1:        +76.0°C

I have an HP Pavilion dv6, Intel i7, AMD Radeon graphics. Please let me know if you need additional information.

What could be different between these two Ubuntu editions that caused such a drastic change?

Edit 1:

Per @Paul's suggestion, I ran htop to try to narrow down the problem. Here is the result!

Left side of terminal

(left side of terminal)

Right side of terminal

(right side of terminal)

This is about 10 minutes after boot-up, htop, yakuake, and a chrome page with 1 tab opened to this question are all that I have manually opened. The most taxing program to the CPU is htop itself. I think that the problem must lie elsewhere; my temps are already up to ~65C for the CPU and ~69C for the GPU, with nearly 0% CPU usage.

Edit 2:

As requested by @psusi, here is the output of 2 tabs from powertop (changed my colors for readability):

enter image description here

enter image description here

enter image description here

enter image description here

Again, all I am manually running is one google-chrome tab and a yakuake terminal. I am fairly new to powertop, so I am unsure how to interpret this. Let me know if you need info from the other tabs.

Edit 3:

I was having battery issues with 12.04 and fixed those by changing some lines in /etc/default/grub; credit this question.

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor pcie_aspm=force i915.i915_enable_rc6=1 i915.lvds_downclock=1 i915.i915_enable_fbc=1" GRUB_CMDLINE_LINUX="pcie_aspm=force"

I have kept these lines the same after updating to 12.10. Do these look OK?

Edit 4:

@Arup Roy Chowdhury mentioned that my AMD drivers might not be installed correctly. I am currently using the following driver (output from software-properties-gtk):

enter image description here

Should I be using a proprietary driver instead? The gnome-shell seems to be running graphics acceleration OK with the open source one.

Edit 5:

@hazrpg I have posted the log files you requested to Ubuntu Pastebin. Here is the dmesg.log, lspci.log, and lsusb.log. See any issues?

Edit 6:

@Sepero Here are my idle temps. I am only running one terminal ~10 minutes after bootup.

Adapter: Virtual device
temp1:        +64.0°C  (crit = +99.0°C)

Adapter: ISA adapter
Physical id 0:  +63.0°C  (high = +86.0°C, crit = +100.0°C)

Core 0:         +62.0°C  (high = +86.0°C, crit = +100.0°C)
Core 1:         +60.0°C  (high = +86.0°C, crit = +100.0°C)
Core 2:         +60.0°C  (high = +86.0°C, crit = +100.0°C)
Core 3:         +63.0°C  (high = +86.0°C, crit = +100.0°C)

Adapter: PCI adapter
temp1:        +68.0°C 

Just opening google-chrome to paste this edit for a minute has raised those temperatures by a few degrees each. My computer was not in the 60s prior to the update.


Problem solved. Thank you to @DrA7 and @YellowApple to pointing me in the direction of graphics card problems. I found this wonderful question and implemented @Nick Andrik's solution. In a nutshell, installing the proprietary drivers (fglrx-updates) from ppa:andrikos solved the problem. I can now use ATI Catalyst to choose my power mode and which graphics card (Intel or AMD) I want to use. My temperatures are down to ~44 degrees and battery life is up to ~4 hours again. I also installed Jupiter, which improved battery and temperatures further.

The open source drivers for AMD seem to be getting better, however it looks like their support for hybrid graphics cards (like mine) is not quite up to spec. Use the proprietary drivers for now.

  • How about powertop?
    – psusi
    Dec 7, 2012 at 3:50
  • @psusi See edits 2 and 3 above. Would additional tabs from powertop help?
    – dinkelk
    Dec 7, 2012 at 4:20
  • Yes, Idle stats and Frequency stats would be helpful.
    – psusi
    Dec 7, 2012 at 15:33
  • @psusi Idle Stats and Frequency Stats are added.
    – dinkelk
    Dec 7, 2012 at 22:51
  • dang, you're pushing the limits there. try installing the fancontrol package.
    – jrg
    Dec 7, 2012 at 22:55

6 Answers 6


I think that it must be related to your video drivers.

Could it be that while using 12.04 you had the proprietary drivers installed but somehow switched to open source after upgrade?

Your problems match mine exactly and I have 12.10 installed on a HP Pavillion G7, with i5 and Intel HD3000/Radeon 6850 graphics hybrid. I would assume that you are currently only using the Intel GPU and that is what is causing your problems. (Yet somehow your GPU temperature reading is the highest...)

I have yet to find a better solution than applying the Grub parameters you described in Edit 3, along with installing Jupiter and setting it to "Power Saving".


Am currently for the first time since upgrading to 12.10 able to display Unity using fglrx after applying the solution you suggested in "FIXED!!", that is, "installing the proprietary drivers (fglrx-updates) from ppa:andrikos" without any further modifications.


Background: ATI PowerPlay vs Open source drivers

Many people are experiencing drawbacks on graphics performance and powersaving capabilities after upgrading to Ubuntu 12.10. This is ascribed to the lack of driver support for X Server 1.13 that comes with the Ubuntu upgrade forcing people to use open source drivers or downgrade to previous versions of X Server. Although the open source drivers has been improved vastly in recent years they are not up to the level of the power management of PowerPlay supplied with the proprietary ATI drivers.

A few things to notice here for others who might be reading:

This only affects HD 4xxx graphics cards and below. Users of later cards should have no problem using the ATI Catalyst drivers. See this question for known issues though.

Possible solutions

I have yet to find fully automated solutions that works at the level of ATI PowerPlay GPU management. However I did stumple accross some interesting tools and tricks that essentially enables you to control the GPU profiles.

Downgrade to previous version of X Server and install Catalyst ATI drivers. Perhaps the most straight forward method is to not use X Server 1.13 at all. Use Tomasz Makarewicz's ppa for downgrading X Server to 1.12 and install fglrx-legacy catalyst drivers. The success to which these packages solves the problems are mixed so you should be mindful about doing this.

To add the repository for the packages type in

sudo add-apt-repository ppa:makson96/fglrx

Update and upgrade the system to apply the downgrade of X server:

sudo apt-get update
sudo apt-get upgrade

and finally install the legacy driver

sudo apt-get install fglrx-legacy

If you wish to uninstall these packages and get back to the Xorg drivers you need to remove the repository and return to the standard version of X server. This can be done using ppa-purge:

sudo apt-get install ppa-purge
sudo ppa-purge ppa:makson96/fglrx

which will automatically remove packages associated with target repository. Simply reboot and you should have the Xorg drivers installed again.

Manual control of the power method

The Xorg drivers provides features for controlling the power methods of Radeon graphics. Dynamic control should be enabled by default, letting the system mange the power profiles itself. To view the current state of power control you can run

sudo cat /sys/class/drm/card0/device/graphics/fb0/device/power_method

This will show either dynpm (automatic control) or profile (manual control). If you wish to control the power profiles yourself you may set it to profile by

sudo echo profile > /sys/class/drm/card0/device/graphics/fb0/device/power_method

and provide a valid profile using

sudo echo mid > /sys/class/drm/card0/device/graphics/fb0/device/power_profile

Possible options are


To re-enable the dynamic power management simply run

sudo echo dynpm > /sys/class/drm/card0/device/graphics/fb0/device/power_method

Radeon Power Profile Manager

Gnome 3 users might be interested in the Radeon Power Profile Manager extension, controlling the GPU profiles from the Xorg drivers. I admit I haven't tested this tool myself, but it is worth a try.

Gnome 3 Radeon Power Profile Manager Extension

  • Thank you for the verbose answer. Installing fglrx-updates from ppa:andrikos (see my final edit) ended up solving my problem.
    – dinkelk
    Dec 11, 2012 at 23:46

I've found that 12.10 (and Ubuntu-based distros based on 12.10, like Linux Mint 14) tend to run really hot with open-source drivers on AMD/ATI GPUs for some reason. Installing the proprietary driver helps - or at least it helped me. Go ahead and give that a try.

  • Thank you for the hint. Installing the proprietary helped fix the problem (see my edit).
    – dinkelk
    Dec 11, 2012 at 23:43

I had high t due to high uncalled CPU usage. Somehow installing bumbleebee paired with installing jupiter reduced CPU usage and t!

sudo add-apt-repository ppa:bumblebee/stable sudo add-apt-repository

ppa:ubuntu-x-swat/x-updates sudo apt-get update

sudo apt-get install bumblebee bumblebee-nvidia linux-headers-generic

  • This seems like a reasonable patch to my system. However, this does not help me get to the root of the problem. I never needed bumblebee + jupiter with 12.04. I should not need it after. I think there is something else going on here.
    – dinkelk
    Dec 9, 2012 at 18:07
  • 1
    He is using an ATI card. As far as I know, Bumblebee is used for NVidia GPUs.
    – Apache
    Dec 11, 2012 at 8:30

The high temperature is most likely due to a heavy load either on the CPU or on the GPU or both.

In your case it seems both are quite hot. I would recommend narrowing down the problem by checking what is using your resources. Issuing the command top or better yet htop in a terminal, then sorting the processes by CPU usage might help you find the task causing the high temperatures.

top is already installed by default. Personally I find htop much more userfriendly though. Hit F6 to sort by CPU with htop.

To install it: sudo apt-get install htop

  • thanks for the suggestion! However, I could not find a problem using htop. See "edit 1" above.
    – dinkelk
    Dec 5, 2012 at 17:21

I had the same problem with both Ubuntu 12.04 and 13.04 on my Sony Vaio SVE1512W1ESI laptop with an AMD Radeon HD 7500M/7600M card. Fan was running all the time and the sensors tool showed temperatures in 60s (started with 56-57 and then went to 67-68 with e.g. browser opened).

I installed proprietary drivers from System Settings --> Additional Drivers but didn't help. Finally, I installed proprietary driver from AMD's website and it fixed the problem.

I followed the following simple steps to install it (as described in the installation instructions manual found on the same webpage):

  1. sudo sh ./amd-driver-installer-catalyst-13-4-x86.x86_64.run
  2. Choose first option (Install driver XX on X.Org XX) and then choose Automatic
  3. sudo /usr/bin/aticonfig --initial
  4. Reboot

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .