I have used Ubuntu before, in virtual machines, but today I decided to make the leap and I bought a netbook to install Ubuntu as a "real" OS alongside Windows. The netbook I bought is an Acer Aspire One 756, with a 64-bit Intel processor, 4GB RAM, and Windows 8 as the default OS.

I have now encountered several obstacles that actually prevent me from installing Ubuntu 12.10. Here are all the things I have tried so far:

  1. Used a live CD, in combination with a USB DVD drive. (I should point out that the Aspire One does not have an optical drive.) The computer does not boot in Ubuntu; the drive keeps spinning, but nothing happens, even though I changed the boot order in the BIOS.
  2. Used a USB drive created via the tool available on pendrivelinux.com. Again, I've made changes to the BIOS to make sure the computer tries to boot from USB before using the built-in HDD. The results vary in this case: sometimes, the computer keeps rebooting like crazy until I remove the USB drive, at which point the computer boots into Windows 8, as expected. If I use a different USB drive, I get an error message that says that the USB drive has been blocked due to "the current security policy".
  3. Tried to install Ubuntu via Wubi. The program appears to install something, but at some point during the installation process, I get a non-specified error message and nothing else happens.

I am not sure if these are known issues; in any case, searching the forum has not yielded any results, so I thought I should simply describe my problem here in the hope that this question has not been answered before. I would greatly appreciate any help with this annoying problem. Of course, if anything is unclear, do not hesitate to ask for further details.


"The current security policy" is probably something to do with UEFI SecureBoot.

See: Shimming your way to linux on Windows 8 PCs

There should be a way of switching this off in your BIOS.

The user guide for your machine available here Acer User Guide suggests that "Boot Mode" in the BIOS should be "Legacy" for a non windows 8 OS

  • Thank you so much! Changing the boot mode in BIOS did the trick. I can now boot via USB and run Ubuntu this way. Of course, this leads to yet another problem: since I now boot in legacy mode, I cannot easily boot back into Windows 8. I need to change the settings in the BIOS again. That is a minor annoyance rather than a real problem, but as a result of that, if I now run the Ubuntu installer, I am not given the option to install Ubuntu alongside Windows. Instead, under the Something else option, I am shown multiple partitions (5 in total) and I do not know which one to choose. – Byron807 Dec 6 '12 at 15:51

I solved this issue time ago: I wrote a guide to install ubuntu together with WIN 8

see my answer here https://askubuntu.com/a/328236/181025

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.