I am trying to play various formats on SMPlayer but none of them have sound, mp4, mp3, flash videos after download from youtube, wav.

These are all playing with GNOME MPlayer, but I require the SMTube tool to watch youtube videos directly on SMPlayer. Sound is enabled. Here it is a screenshot.

  • I had the same problem a while back. 2 things to consider: check in sound settings if the audio source is selected and install pavucontrol. For me THE tool for checking audio related problems. – Rinzwind Dec 4 '12 at 21:26

As Rinzwind suggested, I went to the preferences (Ctrl+P), audio tab and changed the output controller from 'pulse' to 'alsa'. Now the sound is back, problem solved.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.