I was having problems with sound (mono only output), so following advice from another askubuntu question I made some edits in /etc/pulse/default.pa.

After rebooting I had no sound at all. So I deleted /etc/pulse/default.pa entirely and tried another reboot. I did not backup the file (stupid, I know).

How to come back to working config?

I tried: sudo apt-get remove pulseaudio, reboot, sudo apt-get install pulseaudio and reboot.

It's still not working. The file /etc/pulse/default.pa is missing.

Here's what pulseaudio and pacmd commands show:

$ pulseaudio 
E: [pulseaudio] main.c: Daemon startup without any loaded modules, refusing to work.
$ pacmd
No PulseAudio daemon running, or not running as session daemon.
  • Note for those just looking for a replacement file - you can search and download the pulseaudio for your ubuntu version and get the file from that!
    – Wilf
    Jul 31 '18 at 22:10

For those who come here at this time or later, especially if you have never messed with the system wide default in /etc/pulse/default.pa, do note that if you have a ~/.config/pulse/default.pa it completely replaces the system wide default.

In other words: If you get the error message

[pulseaudio] main.c: Daemon startup without any loaded modules, refusing to work.

check if you intentionally or accidentally have a file at .config/pulse/default.pa

If yes, try to move it to a backup location, and then restart pulseaudio. For example with opening a terminal, then typing

mv .config/pulse/default.pa ~/default.pa.bak
pulseaudio -vvvvv

If you now see lots of lines scroll by, more specifically statements of modules loaded, then you know that you have solved the original issue.

Because this is hard to track down, especially if you are forgetful (like me), or because you got convinced by one of the many web pages dealing with pulseaudio issues that you should have a default.pa in the first place, there's already a launchpad bug filed against the behaviour that a user specific default.pa replaces the system wide default.pa. Thanks to Jim Carter for pointing me in the right direction.

Now, if you also must fix the issue that pulseaudio at startup always directs sound to the wrong device, then you can configure your ~/.config/pulse/default.pa to hardcode the default output device with statements such as

set-card-profile 0 output:analog-stereo
set-default-sink 1

This is what I used to have in my config file, in order to prevent the computer from trying to output sound through HDMI connections. However in order for this to work, you would still have to add all the content of the /etc/pulse/default.pa file before those statements. Since that is error prone - consider what happens when the next apt-get dist-upgrade changes the system wide defaults - you can source the default config before your own statements.

My full user specific pulseaudio config file thus is

.include /etc/pulse/default.pa

set-card-profile 0 output:analog-stereo
set-default-sink 1

Btw, the full list of commands usable in these config files can be listed in a terminal by typing

man pulse-cli-syntax
  • I found one at ./pulse/default.pa? Oct 15 '16 at 2:06

Here's my default.pa file. Try putting it in the original folder, making sure it has the right permissions.

Next time backup important files before you modify or delete them, but I guess you learned that lesson already.

  • I used the file kindly provided by @To Do. It worked - I can see devices now in "System settings/ sound". I also had to 'sudo apt-get install indicator-sound' to have sound icon on menu bar back (it disappeared after removing pulseaudio and did not reappear after reinstall).
    – Vlad K.
    Dec 5 '12 at 11:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.