I'm using Google Chrome as default web-browser because i need Flash ang i've installed Firefox back to use with Webapps, because Chromium, that i tried to use before, launched through script, taking Pepper Flash from Chrome, isn't working correctly: Webapps are crashing, clicking on their icons in Launcher or in Messaging menu does nothing and by clicking on web-links from the other applications, opens new clean Chromium window.

I've tried to fix it, and got only half-result as i'm telling here, so Chromium was purged, Google Chrome became default browser again and Firefox was installed for Webapps purposes.

And now, when i'm trying to launch webapp, Google Chrome starts in new window, with all it's plugins in memory, and webapp's icon in Messaging menu is inactive: no any updates info, etc, webapp's icon in Launcher doesn't appear. If i'm launching Firefox and opening Facebook, for example, there is icon in Launcher and there is information in Messaging menu.

I tried to write in .local/share/applications/mimeapps.list and in /usr/share/applications/defaults.list what browser unity-webapps-runner should use but it seems there is no way to do so.

I tried to change "Exec" string .local/share/applications/facebookfacebookcom.desktop to Exec=firefox 'http://facebook.com' %u and after that by clicking on Facebook's icon in Launcher Firefox started, but just once. After it's start, facebookfacebookcom.desktop rewrites with default "Exec" string and at the next time Google Chrome's new window opens.

Is there any way to tell webapp in what internet-browser it should start?

Upd. I tried to copy .desktop file from .local/share/applications/ and to change "Exec" string there. Firefox is launching correctly after that every time and opens second Facebook icon in Launcher :) So this desision also isn't acceptible.

2 Answers 2


I think not, but there is a feature request open about it.


Not exactly the answer you are looking for, but there is another way to launch a webapp —or standalone-dedicated internet browser window—.

1.- Launch chrome/chromium and open the page you want

2.- Open File > Create application shortcuts...

Desktop shortcut

3.- Save only «Applications menu»

4.- You can edit the file, which is created in ~/.local/share/applications. For instance, I usually download a high-res icon and save it in ~/.local/share/icons. Then, I edit the .desktop file.

  • This doesn't work in Ubuntu 16.04 because there isn't an option for Create application shortcuts... in the file menu.
    – karel
    Nov 29, 2017 at 8:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .