Today, I tried to install the Cisco AnyConnect VPN Client on my computer running Ubuntu 12.04 updatet earlier today. I followed the instructions on this webpage https://innsida.ntnu.no/wiki/-/wiki/English/Install+VPN, but after I had typed in my username and password, it failed to connect and my computer was no longer able to connect to the internet.

It finds my router with no problems and it pings my DNS server as normal, but it times out when I try to ping www.google.com for example.

I realize that more information is probably necessary for anyone to help me, but I don't know much about networking.

best regards


Cisco AnyConnect VPN Client makes changes to /etc/resolv.conf. Make sure that the program restored /etc/resolv.conf to its original state. /etc/resolv.conf should be a symbolic link to "../run/resolvconf/resolv.conf". If this is not the case then run

sudo dpkg-reconfigure resolvconf

I had the same problem. With Ubuntu 12.10 I had installed Cisco AnyConnect, then found that I had lost my internet connection. I uninstalled AnyConnect, then saw that I was still having DNS problems, which prevented me from accessing anything on the Internet. Based on jdthood's answer, I looked at the file /etc/resolv.conf and saw this:

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)

127 is a localhost or something, so that didn't look right. I commented out the last line and added this:

nameserver is the ip address of Google's DNS server. That solved the problem instantly. I'm not sure it's a permanent fix (judging by the all-caps warning not to do what I did), but it holds after rebooting, and my internet works again.

  • Your answer doesn't work well with NetworkManager. It deliberately configures /etc/resolv.conf to point to localhost. Sadly, that's as far as my NetworkManager knowledge goes.
    – Flimm
    Apr 4 '13 at 8:45

My case:

Ubutu 14.04, installed vpn by

sudo apt-get install network-manager-openconnect-gnome

then change the /run/resolvconf/resolv.conf to


Now I can connect to internet with CISCO vpn.

the problem is once you disconnect VPN and reconnect VPN, the nameserver is written back to You have to manually change it back.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.