I've installed Ubuntu 12.10 a few days ago and I have only been able to get up to one hour of battery life. When running Windows 7 I get up to 3-4 hours.

My screen is ultra bright, even though the screen brightness is set to the minimum (I installed xcalib to dim my screen, but it doesn't improve the battery life)

I read about Jupiter and installed it, but it doesn't have a noticeable effect.


Quick disclaimer, Linux tends to use more power then windows because it does "more stuff" and uses the hardware different. You may not be able to get the same amount of time in Linux as you did in windows, or you may get more.

These are listed in the order of importance to me. That is the easiest to do with the most gain first.

CPU Frequency

The largest impact on my battery is CPU frequency. When I am plugged in I want full speed, but when I unplug I want as much battery as I can muster. This is mostly automatic, these days, however to give it a bit of a hand, and to let me see it, I installed jupiter. This auto does stuff when on battery and when on power. It also gives me some direct control over some power management features.

Display Brightness

Just turn it down as far as you can. This made a large difference to me. If you want to do this via a script then echo -n 100 > /proc/acpi/video/VGA/LCD/brightness should would with a little adjustment. The path will likely be different depending on build/kernel/hardware.

Keyboard backlight

On My Mac Book Pro, this has only a little gain, but turning off the keyboard backlight is super easy.

Idle Time and Screen Blanking

Turn them way down. From "Power" in unity, set suspend when inactive to 5 minutes, and when the lid is closed suspend. There is a link in the Tip at the bottom of the window. Click it and make sure that Dim Screen to save power is checked. Turn screen off after 2 Minutes.

Turn Off Bluetooth

Again an easy one that doesn't save a lot. From Jupiter indicator, disable Bluetooth when on battery.


Edit /etc/fstab and add noatime to all local partitions and mount points. This "should" prevent your drive from spinning up as frequently. Read up on it first. This doesn't give the benefit it once did, but it keeps my drive from spooling.

Do less stuff

This one is kinda tricky, but can give you a ton of savings. Basically Linux does a ton of stuff in the background. This is one of the best things about it. However it can also lead to higher then needed power usage. The easiest thing to do here is disable cron on battery but turn it back on when on power. This can be dangerous if you don't know what you doing. Basically it shouldn't hurt anything if you miss a few cron jobs, but leaving it off all the time will cause problems.

Also take a look at/keep an eye on htop. Reconsider the apps that are using a large amount of CPU.


I have no idea if this actually does anything so I put it last. Turn nvidia's (if you have it) powersaving on high. nvidia-settings -a [gpu:0]/GPUPowerMizerMode=0 should accomplish that. Side rant, compiz keeps my card from going below the max an awful lot. They need to fix that.


These should help you get a reasonable level of battery performance from your ubuntu laptop.

  • Thanks for the tips, how can I disable unwanted processes/services or their linux equivalents? – Cube Dec 3 '12 at 23:41
  • This should help – coteyr Dec 4 '12 at 2:09

It sounds to me that you might possibly be having problems related to hybrid graphics.

A potential solution is outlined here by user venem in a semi-related question regarding battery issues on ATI/Intel hybrids.

You might also want to check which graphics driver you have installed by opening software-properties-gtk and having a look at the "Additional Drivers" tab.


Using a proprietary driver tripled my battery life.

  • Thanks for your answer. I agree, it’s probably a problem related to the GPU , I tried switching to the proprietary drivers. Ubuntu booted in low graphics mode (the battery lasts for like 3 hours this way), I tried the solutions given in the thread you showed me, but they didn't worked for me. I even tried installing the drivers from support.amd.com to no avail. I also found about a gnome extension that can change the radeon's power profile, that way my battery lasts for an hour and a half. – Cube Dec 20 '12 at 23:46
  • If you have a ATI/Intel hybrid then the only installation method that has worked so far for me is outlined here; askubuntu.com/a/207270/82517 – DrA7 Dec 21 '12 at 15:03

Here is a script for setting up automatic screen dimming when unplugging the cable: http://www.vivaubuntu.cu.cc/dim-screen-backlight-on-when-on-battery/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.