24

I faced a "The system is running in low-graphics mode error" like the on in this question How to fix "The system is running in low-graphics mode" error?

This happened in Virtualbox!

I'll go with the answer that the root file system ran out of space since I left the system downloading some stuff & previously I was notified that the system is low on space. Dumb of me but everyone makes mistakes. I was planning on moving the files to a shared folder later on.

The screen I get is similar to the screen in the link above. If I click on Ok, I get the following screen

None of the options work. I even tried to use the shell mode to try to free some space but all I get is this screen

So my question is how can I get back to my system & move the files to the shared folder (which btw needs guest additions which is was already installed on the system!) or better (if easier) an USB?

Note: I tried a live mode (iso) but I cannot do anything (e. G; open nautilus or a terminal!); + I get a VERP_PDM_MEDIA_LOCKED_error when try to install guest additions.

  • I encountered this error immediately after installing guest additions under vbox 4.2.12. Reverting to 4.2.10 fixes it. I suggest saving state just before upgrading guest additions with each new vbox release. – wberry Jun 13 '13 at 21:54
11

A Virtual Box Ubuntu behaves very similar to Ubuntu on bare metal. Therefore the solutions from this question

mostly hold true as well. However note, that you do not have a graphics card or proprietary drivers in a VM. This will all be handled by the guest additions.

We can enter a TTY for command line repair by press and hold the HOST-key, which in your case is the right Ctrl-key and simultanously press F1 trough F8.

In case your virtual hard drive runs short of memory try first with

sudo apt-get autoremove
sudo apt-get autoclean

to remove no longer needed packages. See also:

|improve this answer|||||
  • Thanks for the TTY thing :) cleared 135+ MB due to a kernel upgrade! :) I was able to log in & after re-enabling guest additions (I removed them when troubleshooting) & rebooted & I was able to access my files & move them (2.5GB). The system is back & running. Thanks :) – user10853 Dec 3 '12 at 22:52
22

I just had the same error with a fresh installed ubuntu 12.04.2 that where just downloaded as well.

Just updating the system was enough for me:

sudo apt-get update
sudo apt-get upgrade
|improve this answer|||||
  • your solution has worked for me. thanks a lot mate. – Felipe Almeida Apr 7 '13 at 6:32
  • Worked for me as well! – manish_s May 14 '13 at 14:41
11

I just recently tried my hand at Ubuntu in VirtualBox and received the same error. For me, the solution was installing the VirtualBox Guest Additions. I followed the instructions listed here, which are essentially:

  1. Before installing the Guest Additions, you will have to prepare your guest system for building external kernel modules:

    sudo apt-get install dkms
    
  2. Insert the VBoxGuestAdditions.iso CD file into your Linux guest's virtual CD-ROM drive and mount the ISO for the guest additions (it can be found in the VirtualBox installation directory):

    sudo mount /dev/cdrom /cdrom
    
  3. Change to the directory where your CD-ROM drive is mounted and execute as root:

    sudo sh ./VBoxLinuxAdditions.run
    

However, it has been a decade since I used Linux, so I had a little trouble finding out where the CD was mounted. I found a post on the VirtualBox forums that gave me the nudge I needed to setup the mount point for the CD, then I was off and running.

|improve this answer|||||
  • +1 Perfectly solved the problem. By the way, Guest Additions can also be found at: download.virtualbox.org/virtualbox. They are located in the respective VirtualBox version folders. Make sure to download the one that matches your respective VirtualBox version. – Rafay Sep 30 '13 at 20:27
2

My host machine is a Windows machine which has an ATI graphic card. The following procedure worked for me:

When the message that "your system is running in low-graphics mode" appears press Ctrl+Alt+F1 to enter the termina. Then login with your credentials, and then run the following commands:

sudo apt-get install fglrx    
sudo reboot

This was an answer posted in another question.

|improve this answer|||||
0

I had the same problem. It turns out I had accidentally edited the file /etc/environment.

To fix this:

  1. Login with sudo command permission.
  2. Edit the file using nano editor.
  3. Make sure that there is no illegal entries in /etc/environment.
|improve this answer|||||
  • I recommend expanding this a bit, as it's unclear what "Login with sudo command permission" means. – Eliah Kagan Jan 18 '13 at 10:01
  • More unclear as to the context of accidentally editing /etc/environment and how others would do that – mrmagooey Sep 1 '13 at 2:20
0

I had the same problem installing a 32 bit VirtualBox guest in a 64 bit Ubuntu 12.04 desktop machine.

64 bit guests in the same environment causes no problems, but the 32 bit guest got the low graphics warning.

The problem seems to be a bug in the display mechanism in the code on the Ubuntu 12.04 CD.

After I logged in through a TTY and did

sudo apt-get update
sudo apt-get upgrade

everything works fine.

Hopefully, this will work out of the box with the next service release og 12.04.

|improve this answer|||||

Not the answer you're looking for?Browse other questions tagged or ask your own question.