I installed gnome-shell right away, and then i noticed that Nautilus main menubar (File, Edit and such menus) is missing. It does not appear inside the File Manager window nor on the "global menubar". (also happens on Unity).

I googled arround, but nothing solved my problem. Things i tried:

  • Purge the appmenu-gtk, appmenu-gtk3, appmenu-qt and indicator-appmenu packages
  • Issue this command on terminal
  • Look for globalmenu in dconf-editor: Could not find it

How can i solve that?

I'm using Ubuntu 12.10, gnome-shell 3.6.1, Nautilus 3.6 Also, I used the gnome3-team repository to install Gnome-Shell


This is completely normal. Since you've activated the gnome3-team PPA, you have the latest version of Nautilus which follows GNOME 3 human interface guidelines (more information here and here).

To access the application menu, clic on the application name on the top bar.

Nautilus 3.6 application menu

You will see the same behaviour with other GNOME 3 software like Epiphany (Web), Empathy or Boxes for example.

I suggest you learn how to use this new version of Nautilus. But if you can't stand it anymore, you can go back to the previous version by purging the gnome3-team PPA (be careful, this will affect every other software provided by the PPA) :

sudo apt-get install ppa-purge
sudo ppa-purge ppa:<nom_du_dépôt>
  • 3
    This menu is not easily discoverable... I understand there is a need to standardize and simplify menus, but this solution is not completely perfect for now (see Empathy or Web for example). – remjg Dec 3 '12 at 14:04
  • Menubar missing in 14.04 and there is no such menu. Even if there were, it would be a very bad thing. – haelix Nov 14 '14 at 10:01

I suggest installing Nemo to have menus and many options long missing from newer versions of Nautilus. It is a fork of Nautilus from the makers of Linux Mint and Cinnamon. There is a way to totally replace Nautilus with Nemo, but that is beyond the scope of this question. Do not uninstall Nautilus even if you have installed Nemo, if you use Gnome or Ubuntu Unity. Nautilus handles your desktop, unless you know how to rebuild Gnome or Unity or some really advanced tricks.

  • where do you get it from? – endolith Nov 27 '13 at 3:12
  • 1
    Sorry I took so long to respond. If you are using any Ubuntu flavor (Lubuntu, Xubuntu, Kubuntu) of at least version 13.10, Nemo is now in the repository. Otherwise, go to launchpad.net/~webupd8team/+archive/nemo or (1)sudo apt-add-repository ppa:webupd8team/nemo, (2)sudo apt-get update, (3)sudo apt-get install nemo. It should pull in some dependencies either way. – Thomas Sisson Dec 10 '13 at 19:40
  • Thank you! I installed it, it has several features/options that Nautilus no longer does. – weronika Feb 12 '16 at 0:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.