5

I am used to making highlights in texts enter image description here

enter image description here

But sometimes after saving the document as .doc I have to open it on a windows OS and cannot undo the highlight. (I haven't checked it in Word 2007 yet)

Is there a solution/workaround to this?

7
  • 1
    Install libreoffice in Windows.....just a thought – Ringtail Dec 2 '12 at 21:46
  • @Rick Green, yes, this is a practical solution, having OO in win when opening the doc file, but see the answer below and the link there (select the mentioned text with the mouse, go to "Format.Borders and Shading.Shading". There select "No Fill") It seems that highlighting in Libre/Open Office does not correspond to highlighting in Word, but to Shading – user47206 Dec 2 '12 at 22:01
  • hummmm...ug! sounds like a BUG! – Ringtail Dec 2 '12 at 22:12
  • that's what it is, but it seems that there's a workaround – user47206 Dec 2 '12 at 22:26
  • I read your discussion related to highlight feature. I am trying to HighLight Text line using python script , but I can't find that How to highLight text Line of any word document document like Gedit ,LibreOffice etc. As shown in 2nd image they highlight text with yellow background , so is that possible that using python script can we highlight specified text/line/sentence ? please help me...! – Dhairya Apr 8 '14 at 6:38
7

UPDATE 2017: This bug was fixed in recent 5+ versions of LibreOffice.

Looks like it was a known issue in OpenOffice: https://issues.apache.org/ooo/show_bug.cgi?id=24317

The bug is presented as:

1) Highlight some word in OOo

2) export document to DOC

3) Open this document in Word - highlighting is visible

4) Try to remove highlighting in Word - nothing happened

The issue should be similar in LibreOffice and so you should be able to remove the highlighting by doing:

  • Select the highlighted text
  • Go to Format, Character and then remove the background (format->paragraph->shading: set to "no fill")
  • Maybe you should remove also some text effects (not sure)

(The 'highlight' option in Libre/Open Office corresponds in MSOffice not to 'highlight', but to 'Shading'. In the old menu of MSO, that is in Format/Borders and Shading/Shading. In MSO 2007 go to Menu, and in the Paragraph group click the bottom right button and look for 'Borders and Shading'.)

6
  • Sorry I misunderstood the problem, I thought you was trying to open a .doc created in Ms Office with LibreOffice. I hope the solution could be similar. – dan_s Dec 2 '12 at 22:05
  • 1
    you gave me the good link. and there's a workaround there (select the mentioned text with the mouse, go to "Format.Borders and Shading.Shading". There select "No Fill") It seems that highlighting in Libre/Open Office does not correspond to highlighting in Word, but to Shading. What about the font colour, it seems that a similar issue is present – user47206 Dec 2 '12 at 22:07
  • 1
    Yes, according also tho this bug report (Libre/Open Office -> Ms Office) you're right, highlighting corresponds to shading: issues.apache.org/ooo/show_bug.cgi?id=24317 – dan_s Dec 2 '12 at 22:13
  • can you dig up a link about a similar issue but regarding the color of the text? as i remember there was such a problem too. can you check? then we could extend the question/answer. with a bit of editing your answer should be the definitive – user47206 Dec 2 '12 at 22:15
  • The only differences I found regarding the font colour are sorted in this post on the OpenOffice community forum: forum.openoffice.org/en/forum/viewtopic.php?f=7&t=782#p3295 I don't know if it is connected with the problem you talked about, but looks like there are no different issues on this feature. – dan_s Dec 2 '12 at 22:41
1

I began a document in MS Word and later opened it in Libre Office.

I had highlighted some words which I was unable to un-highlight in Libre.

What didn't work:

I tried no fill options in the highlighter

I tried no fill under format character/background option

What did work:

Ctrl + M Or in the format menu at the top click "clear direct formatting"

0

Edit: As @N0rbert and @dan_s point out, the bug is fixed in the newest versions of LibreOffice. However, for removing highlighting from text in old LibreOffice files, you can press the Clear All Formatting button, and then re-apply all of the intended formatting.

3
  • 1
    Please delete your post. It is not actual anymore. The bug is fixed in LibO 5.0. – N0rbert Dec 4 '17 at 17:35
  • @N0rbert - This seems fixed indeed. If you post your comment as answer I will mark it as definitive. – user47206 Dec 5 '17 at 10:10
  • Highlighting in MSWord can be undone in LOWriter and viceversa. Tested with MSWord 2010 (installed in Linux/Playonlinux) and LOWriter - 5.1.6.2 – user47206 Dec 5 '17 at 10:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy