I have a non stopped problem in my Acer Aspire 5733 model using Atheros ath9k driver. WiFi is working when router is in nearby location, there is nothing updates by Acer for Linux. I also using rfkill list all command to check switches, it shows:

Soft blocked: no
Hard blocked: no

I searched everywhere on Ubuntu forum but didn't find any result for Aspire 5733, also I couldn't found any firmware for Atheros like Broadcom. This is a big disadvantage of Acer with Ubuntu. Also, I do some stuff to resolve this problem is to create a file named ath9k.conf:


with the contents:

options ath9k nohwcrypt=1

Please suggest me optimal solution for this problem.

7 Answers 7


Beside creating a file named /etc/modprobe.d/ath9k.conf with the contents options ath9k nohwcrypt=1, I also had to disable acer_wmi kernel module:

sudo nano /etc/modprobe.d/blacklist.conf

and add this line:

blacklist acer-wmi

Then reboot. This fixed WiFi problems for me.

  • 1
    It did not work for me (Acer TravelMate 5735Z, Linux Mint 15 (Ubuntu 13.04)). Oct 17, 2013 at 17:01
  • This solution also worked for Fedora 31 on a Acer Aspire 4750 Jan 16, 2020 at 23:58

I know it's bit old question, but this solution bellow may help other people stuck with ath9k driver on Acer laptops.

Try to compile ath9k driver following this procedure on Ubuntu Forums


sudo apt-get install linux-headers-generic build-essential

Download this to your desktop backports-3.12.2-1.tar.bz2

Compile using bellow comands

cd ~/Desktop/backports-3.12.2-1/
make defconfig-ath9k
sudo make install
sudo modprobe -r ath9k && sudo modprobe ath9k

Your wireless should be working now. Note this will work until next kernel update. After kernel update you will need to recompile the driver again. Command are similar to ones above.

cd ~/Desktop/backports-3.12.2-1/
make clean
make defconfig-ath9k
sudo make install
sudo modprobe -r ath9k && sudo modprobe ath9k

I had problems with the Atheros ath9k driver when I upgraded my kernel to fix some power management issues.

Tried the ath9k.conf file but it did not work.

Then I downloaded a driver and it solved my WiFi problems. This was what I did:

Go to wireless.kernel.org and download the appropiate driver for your kernel.

Check kernel version in terminal: uname -a

Unpack the file you just downloaded in a new folder into your downloads folder.
(it should be something like Downloads/compat-wireless-3.5.4-1-snp)
(beware: your filename might be different)

You will probably need the build tools; open a terminal and type:

sudo apt-get install build-essential linux-headers-generic

Then after you have installed build-essential and headers, please do:

cd Downloads/compat-wireless-3.5.4-1-snp
sudo su
make install
modprobe -r ath9k
modprobe ath9k

My computer crashed shortly after the 2nd modprobe, but when I restarted everything ran lightspeed.

I'm running on an Aspire 5750Z. Hope it helps.


This probably won't help for the original question. But, for those using newer versions of Ubuntu, the package firmware-ath9k-htc is available. Solved my wireless issue by simply installing it & restarting.

My system is an older MacBook Pro (around 2007 or 2008 I believe) with Ubuntu-MATE 19.04.

$ lspci
b:00.0 Network controller: Qualcomm Atheros AR5418 Wireless Network Adapter [AR5008E 802.11(a)bgn] (PCI-Express) (rev 01)

Try changing the "WPA group rekey interval" on your wifi router.. this is working for me now.. it was set to 2 before I changed it to 3600. This value is in seconds.. This is working for me now,I tried disabling hardware encryption and power mangagement, but that did not work..

I am now trying other combinations..by enabling power mangement and hardware encryption on again and by lowering the interval time to 60 seconds.. as these are desirable for security :)


Well It is certainly not a optimal solution but a workaround, but what works for me is to request dhcp in a loop i.e.

watch -n5 sudo dhclient -v wlan0

Then I have intermittent connection via wireless router. I am using Hp ProBook 4540s and Linksys WRT 54GL


You can give a try to ndiswrapper, it allows you to run windows drivers in linux. Check out previously asked question here Need a few reboots to connect to wireless

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .