40

I recently installed ubuntu 12.10 and it seems as though my clock is missing. I also don't see any options for date/time in the system settings panel.

enter image description here

enter image description here

Am I missing something? Again this is with Unity.

4
  • 5
    in my case it was running but bugged, I could not change settings and so; I did pkill -f indicator-datetime and it instantly worked again! Jun 4, 2014 at 23:52
  • @AquariusPower This worked for me as well too under 14.04 LTS. Thanks
    – seb
    Jun 17, 2014 at 10:00
  • That worked for me also under 14.04. I guess the clock is just buggy.
    – John Scott
    Aug 31, 2014 at 15:33
  • none of the solutions worked for my unbuntu16 where my clock disappeared after some automatic update.
    – Kemin Zhou
    Feb 23, 2018 at 0:10

5 Answers 5

105

As per the comments above I've fixed this issue on my brand new 14.04 LTS installation by running.

$ pkill -f indicator-datetime-service

The clock came straight back.

3
  • 4
    interesting, none of the other tips worked for me, this did. thx.
    – towi
    Jul 3, 2014 at 7:35
  • 2
    This should be the accepted answer. (At least if the question were for 14.04.4 LTS.)
    – Peterino
    Apr 19, 2016 at 20:31
  • This is the one that worked for me. Shell-only answers deserve extra points.
    – rubicks
    Mar 9, 2018 at 17:43
17

Open a terminal window (Ctrl+Alt+T), then run the following:

killall unity-panel-service

This command should reset the panel, and hopefully reactivate the clock indicator.

1
  • To make it more convinient you can also create an alias in ~/.bashrc or ~/.bash_aliases. alias restart-clock="killall unity-panel-service"
    – sobi3ch
    Mar 14, 2015 at 11:32
13

This could be one of two things, either the clock isn't installed, or a setting has been flipped to turn it off.

First make sure the clock is installed by making sure indicator-datetime is installed:

Install via the software center

Then log out and back in. If it's already installed and it's still not showing up, try the options here:

If that still doesn't work update your question with the results, thanks!

1
  • 2
    Thanks for the hints! A simple sudo apt-get install indicator-datetime fixed the problem!
    – Brian
    Dec 1, 2012 at 23:38
1
sudo apt-get install indicator-datetime

and logout/login.

1

Worked for me:

sudo apt-get install indicator-datetime
sudo dpkg-reconfigure --frontend noninteractive tzdata
sudo killall unity-panel-service

Reference: https://askubuntu.com/a/357280/25184

3
  • No need for sudo before killall. Mar 6, 2014 at 11:40
  • 3
    In my case killall unity-panel-service was enough to bring the clock back. Jul 13, 2014 at 10:01
  • Also works on Ubuntu 14.04. Jan 16, 2015 at 13:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.