14

I can't mount my SD card. I'm using Ubuntu 12.04 LTS on an Asus K55V (Intel), and I have a sd card slot, but Ubuntu doesn't detect when I put a SD card in the slot. Not Ubuntu nor other program.

  • Make sure there's a formatted card in the slot and run the following commands: "sudo fdisk -l" and "blkid". Paste the results back into your question so that we can have a look. – fabricator4 Dec 1 '12 at 19:20
  • Have you checked the filesystem if the card is exfat you have to install exfat fuse for mounting it. – Chinmaya B Aug 14 '15 at 10:51
18

Run these commands from a command prompt:

sudo modprobe -r r852
sudo modprobe -r sdhci_pci
sudo modprobe r852
sudo modprobe sdhci_pci

This uses modprobe to unload and reload the device drivers (in this case kernel modules) to automatically detect the SD card into the kernel.

Source codes

| improve this answer | |
  • genius, it works in ubuntu 13.10 64 – lalo Feb 25 '14 at 1:29
  • 2
    It works on ubuntu 14.04 32 also – pylover Jul 9 '14 at 16:53
  • 7
    Doesn't work for me. Ubuntu 14.04 64 – VukBG Aug 3 '14 at 11:22
  • Doesn't do anything for me in Ubuntu 12.04. – Cerin Feb 6 '15 at 19:15
  • Works on Ubuntu 14.04 64-bit after running the command, then taking out the SD card and putting it back in again. Thanks a ton! – Ads20000 Feb 7 '15 at 17:04
0

For Broadcom Corporation BCM57765/57785, in addition to the answer below, I had to add lines to modprobe.d (before commands above)

$ sudo sh -c 'echo options sdhci debug_quirks=0x40 >> /etc/modprobe.d/sdhci-pci.conf'

AND

$ sudo setpci -s 00:1c.2 0x50.B=0x41

[source]

| improve this answer | |