I try to add .pls radio station to rhythmbox. I download the file and I click music>import file but nothing happen. I added one station before and it works fine but now it simply does not work. Also when I try to get from the file, click on open with rhythmbox I have the error:

Couldn't start playback
Problem occurred without error being set. This is a bug in Rhythmbox or GStreamer.

I have all medibuntu installed and I have one radio station already playing. I don't know how to proceed from now and what should I check if there is something to fix. Anyone get similar problem?

(Ubuntu 12.04 64-bit Gnome3)


With my version of rhythmbox (2.96) on 12.04, the .pls radio stream plays fine. Choose a stream from the site you are interested in; I chose this 128k mp3 stream from the site you mentioned and added it with Music > New Internet Radio station (as in the screenshot below).

enter image description here

Then on the sidebar (see screenshot below) click library > radio and the new station will probably be listed in the unknown genre slot. So then just double click the new station there.

It is also important to note that when you import a radio stream rhythmbox will sometimes assign a gender to it ('Space Electronica') and sometimes not. So, for example, this stream was to be found in 'Experimental Nujazz' when imported. If you can't find the station in the program's list, look through the genres or 'unknown' and double click a station if it doesn't play automatically.

If the stream doesn't play correctly, I should choose an alternative, as there are usually several available; for example, on this page the asx stream played the best.

enter image description here

In general, experiment with the different stream options available on the radio site you are interested in as rhythmbox has good support for .pls and .asx feeds, etc, when the necessary gstreamer plugins are installed.

If you can't get the .pls file working, you could just open it in a text editor and extract the url and then add that as a radio station in Rhythmbox, using the process I mentioned earlier in my answer.

You could also try installing the excellent rhythmbox-plugin-radio-browser from the ppa of one of our moderators, fossfreedom; do not install the version in the repositories as that version does not work with the current Rhythmbox.

sudo add-apt-repository ppa:fossfreedom/rhythmbox-plugins
sudo apt-get update
sudo apt-get install rhythmbox-plugin-radio-browser 

You have to enable it by going to edit > plugins first.

enter image description here

More on the plugins available is explained here:

|improve this answer|||||
  • Strangely enough it does not show in my Rhythmbox and I don't have a clue why. Previously with ubuntu 10.04 it was not a problem to add a radio station in the way you described. Now with ubuntu 12.04 it simply does not work. – tomasz74 Dec 9 '12 at 11:42
  • @tomasz74 see my edit. – user76204 Dec 10 '12 at 22:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.