25

I have a problem when I try to connect my guitar to my computer, via line input. Audacity works well, and I can record what I play on my guitar (selecting from Preferences from where to record to default:line0). But the problem is in Qjackctl : at first when I click on start it shows this error:

error 1

after that when I click on Cancel it gives this error:

error 2

This is the log from the messages window:

10:30:37.368 Patchbay deactivated.
10:30:37.416 Statistics reset.
10:30:37.459 ALSA connection change.
10:30:37.497 D-BUS: Service is available (org.jackaudio.service aka jackdbus).
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
10:30:37.512 ALSA connection graph change.
10:30:44.060 D-BUS: JACK server could not be started. Sorry
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
Sat Dec  1 10:30:43 2012: Starting jack server...
Sat Dec  1 10:30:43 2012: JACK server starting in realtime mode with priority 10
Sat Dec  1 10:30:44 2012: control device hw:0
Sat Dec  1 10:30:44 2012: control device hw:0
Sat Dec  1 10:30:44 2012: [1m[31mERROR: Failed to acquire device name : Audio0 error : Method "RequestRelease" with signature "i" on interface "org.freedesktop.ReserveDevice1" doesn't exist
[0m
Sat Dec  1 10:30:44 2012: [1m[31mERROR: Audio device hw:0 cannot be acquired...[0m
Sat Dec  1 10:30:44 2012: [1m[31mERROR: Cannot initialize driver[0m
Sat Dec  1 10:30:44 2012: [1m[31mERROR: JackServer::Open failed with -1[0m
Sat Dec  1 10:30:44 2012: [1m[31mERROR: Failed to open server[0m
Sat Dec  1 10:30:45 2012: Saving settings to "/home/gevorg/.config/jack/conf.xml" ...
10:31:11.438 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started

Now I can't understand what my problem is.

  • I tried the command lines: pulseaudio --kill jack_control start and I got a message: "DBus exception: org.jackaudio.Error.Generic: Failed to open server" What could be the problem? – user145336 Mar 29 '13 at 18:44
  • Came here looking for the answer to very similar question, but it turns out that my USB guitar-link cable was unplugged, and plugging it back in, ensured that this error doesn't pop. – icarus74 Dec 22 '15 at 3:59
22

Try this from the command line:

pulseaudio --kill  
jack_control  start

Then when your done do this:

jack_control exit  
pulseaudio --start

And sometimes jack wont die, so then do

Get jackd's PID:

ps -aux | grep jackd  
kill -9 jacksPID
  • 14
    sorry for late response, but when i try jack_control strt it brings error: --- start DBus exception: org.jackaudio.Error.Generic: Failed to open server – hingev Jan 3 '13 at 12:12
  • 1
    The issue with this is that pulseaudio aggressively restarts. – Pointy Feb 18 '13 at 22:24
  • Oh my goodness, thank you so so much. This is fairly useful in the context of running Overtone and Chuck – Ehtesh Choudhury Aug 1 '13 at 6:19
  • 1
    geoh why did the error stop for you, did you change something in the above command? I'm stuck with the same issue when I try this solution. – TenLeftFingers Nov 22 '14 at 13:51
  • pasuspender qjackctl suspends pulseaudio so that jack can be started – Alexander Sep 9 '18 at 8:57
21

None of these solved my problem. This did: http://dpod.kakelbont.ca/2015/08/16/fixing-qjackctl

  1. In a terminal start qjackctl:

    qjackctl
    
  2. Before you try to start it, click the Setup button in the GUI (right-hand side, middle).

    enter image description here

  3. On the setup GUI change Input Device and Output Device (middle, right-hand side) from (default) to hw:PCH (In the screenshot one has been changed and the other has not).

    enter image description here

  4. Restart qJackCtl. You should now be able to successfully use the Start button.

  • 1
    You are my savior. I tried all the mess with killing pulseaudio and restarting jack_control - all in vain. But your solution worked! – user3804598 Dec 10 '17 at 13:46
  • You are my life savior! – Zack Lee Sep 21 '18 at 13:26
  • This is the recommended method according to JackAudio.org Option #4: – xtrchessreal Jan 7 at 19:02
9

I made it and solved:

sudo killall -9 jackdbus
  • THANK YOU SO MUCH!!! This worked for me and is the only answer I've found that actually made sense according to the error messages ERROR: cannot register object path "/org/freedesktop/ReserveDevice1/Audio0": A handler is already registered for /org/freedesktop/ReserveDevice1/Audio0 Thank you again! – Jesse the Wind Wanderer Oct 13 '15 at 10:30
5

I solved the error d-bus jack server could not be started by deleting

~/.config/rncbc.org/QjackCtl.conf

and restarting qjackctl. In my case, I had messed up the settings, and it was stored in this file.

  • Fixed it for me in Fedora. – Forivin Dec 1 '17 at 10:14
  • This worked for me as well. – Kris Apr 12 at 20:46
3

I used sudo killall -9 jackdbus

Then sudo qjackctl

That worked! But i don't get any sound and can't get my ffado mixer to run after that.

2

There are a lot of relevant explanations here:

http://jackaudio.org/faq/pulseaudio_and_jack.html

I have solved my problem after prefixing the server path with pasuspend -- and choosing the appropriate Interface (upper right corner) to the right sound device in my system, by clicking the > symbol and choosing from the list.

1

Running QJackCtl from commandline as root user fixed the issue for me.

sudo qjackctl
  • I run "sudo qjackctl" and my Ubuntu has frozen. Had to hard reset my pc. – user3804598 Dec 10 '17 at 12:50
0

Step 1. View audio cards

cat /proc/asound/cards

(view audio cards)

Step 2:

pulseaudio --kill

Step 3:

qjackctl 

In GUI find Interface:[default] and choose relevant audio card

Press play |>

Step 4:

Run process requiring jackd (in my case, sonic-pi) then, when you're all done...

Step 5:

pulseaudio --start

This is sort of a mashup of the previous answers, but it worked for me while none of the single answers did. It helped me to read a little about the differences between pulseaudio and jackd.

I hope this helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.