7

I have installed MonoDevelop and after that Wine, but when I want to open an EXE file and then double click on it, it always runs with the Mono runtime, and if I want to run it with Wine, I should right click on it and choose Wine.

Well, in properties and in show other applications there isn't Wine that choose it for the default application... I have this problem for all types of applications and files.

When the software you want to run is in the right click application (Open With), I can't choose it in properties for the default. In fact, I can't find it in properties, because it is in open with option in right click...

What should I do to fix this problem?

I'm running Ubuntu 12.10 (Quantal Quetzal), 32 bit.

7

first of all, add your new MimeType :

from the terminal open sudo gedit and copy the code bellow

[Desktop Entry]
Version=1.0
Encoding=UTF-8
Hidden=false
Icon=my/icon/path                           <-- optional (for the file icon)
Type=MimeType
Patterns=*.xxx                              <--- my file extention 
MimeType=application/myAppName              <--- the mimetype of the file
Comment=My Comment

and save it to /usr/share/mimelnk/application/myApp.desktop "replace myapp with your app

linking your app with this mimetype:

use ubuntu Tweaks to link the file type with your app

note: the wine apps is located on the path /home/<userName>/.wine/drive_c/Program Files/Notepad++

also you can use locate 'yourApp.exe' to find its path

3

It sounds strange. When I go to Properties I do find the applications in the Open with list.

Right-click on a .exe file, click properties, choose the Open With tab, choose Wine (if not present in the list click "Show other applications" and click "Set as default."

That's it.

  • 1
    thanx but as i said it is in the open with list my problem is i can't set it to default program for run i'm really confused ... – Mohammad_Hosseini Dec 1 '12 at 9:41
  • 1
    no you got me wrong . I said when I click on a EXE file in right-click it shows me wine but I want to set wine as default . like I said in properties it doesn't show wine so I fixed it with ubuntu tweaks file type manager – Mohammad_Hosseini Jan 19 '13 at 14:26
3

i have solved this problem with ubuntu Tweaks it has a software manager that you can set default program for each file type ...

0

Better way to create the mime type:

sudo apt-get install assogiate

or see here for article on how to use http://www.packtpub.com/article/control-of-file-types-in-ubuntu

Then use Tweak to make the link:

sudo add-apt-repository ppa:tualatrix/ppa
sudo apt-get update
sudo apt-get install ubuntu-tweak

Or see: http://www.noobslab.com/2012/10/install-ubuntu-tweak-081-in-ubuntu.html for a walkthrough.

And if everything else fails....like all the above did for me:-( Use mimeopen -d (sudo apt-get install libfile-mimeinfo-perl if you do not have it) That finally fixed it for me...

0

I didn't use "Ubuntu Tweaks". Just did the following (after hours of search):

In ~/.local/share/applications create a npp.desktop file, with the following code:

[Desktop Entry]
Type=Application
Name=Notepad++
Exec=wine /home/<user>/.wine/drive_c/Program\ Files/Notepad++/notepad++.exe

In the mimeapps.list write application/x-php=npp.desktop (for the php types, in my case).

And that's it.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.