I just upgraded to 12.10 on my Lenovo B570 laptop. NetworkManager isn't displaying a submenu for wireless connections at all, even though I downloaded the update through the wireless connection. This displeases me.

Stuff I've tried includes:

$ sudo modprobe wl
FATAL: Module wl not found.
$ sudo lspci -nn | grep "BCM"
02:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)
$ rfkill list all
0: ideapad_wlan: Wireless LAN
        Soft blocked: no
        Hard blocked: no

ETA: linux-headers-generic is already the newest version, and what I get when reinstalling bcmwl-kernel-source includes the following, near the end.

DKMS: install completed.
ERROR: Module b43 does not exist in /proc/modules
ERROR: Module b43legacy does not exist in /proc/modules
ERROR: Module ssb does not exist in /proc/modules
ERROR: Module bcm43xx does not exist in /proc/modules
ERROR: Module brcm80211 does not exist in /proc/modules
ERROR: Module brcmfmac does not exist in /proc/modules
ERROR: Module brcmsmac does not exist in /proc/modules
ERROR: Module bcma does not exist in /proc/modules
FATAL: Module wl not found.

ETA2: Solved! Turned out the problem was that I'd been running the 3.0 kernel instead of 3.5 -- meaning the seeds of this problem have been lurking around for at least half a year. chili555's answer helped me discover this, though it took a little longer to find out how to boot to 3.5.

  • Is there an error further up? Is a log referred to,similar to this: "Consult /var/lib/dkms/bcmwl/ for more information." If so, let's see what it says: cat /var/lib/dkms/bcmwl/ or whatever is mentioned in your installation. You might also try the sequence as I edited below.
    – chili555
    Nov 30, 2012 at 17:02
  • No such reference.
    – Shay Guy
    Nov 30, 2012 at 18:03
  • Glad it's solved.
    – chili555
    Nov 30, 2012 at 22:10

1 Answer 1


Please hook up the ethernet temporarily and do:

sudo apt-get install --reinstall linux-headers-generic linux-headers-`uname -r`
sudo apt-get install --reinstall bcmwl-kernel-source
sudo modprobe wl

The backticks are on the left side of my US keyboard on the same key with ~. It it working now?

  • Nope. Same result. Updating the question with details now.
    – Shay Guy
    Nov 30, 2012 at 16:41
  • @ShayGuy Maybe a reboot needed after the re-installation for the changes take effect. Try it.
    – NickTux
    Nov 30, 2012 at 17:05
  • My kernel release is 3.0.0-14-generic. Is that the problem?
    – Shay Guy
    Nov 30, 2012 at 18:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.