Nautilus File Search is not working. It is as simple as that. Nothing is ever found.. Nothing happens... (Nautilus 2.30.1, on Lucid 10.04)

The same version of Nautilus running in a VM works fine, so I know I'm doing the right thing.

One "difference" I've noticed between my problem Nautilus and the VM Nautilus, is that the "Reload" button never appears... (nor does any list of files ever appear)...

I've tried removing ~/.nautilus (no effect)
I've reinstalled nautilus ... (no effect)

I'm a bit wary of doing a full reomoval of nautilus (and then a new install), because I don't know how this will effect the desktop integration; specifically... what is going to happen to my nautilus notes, which are tenuously attached to files via a feature of nautilus.. .


I've got it working again, by purging Nautilus...
I first made a backup of my plugins and extensions data ...
Nautilus Notes and other metadata are in '~/.local/share/gvfs-metadata'
'nautilus-scripts-manager' data is in '~/.gnome2/nautilus-scripts' ... etc.

  • apt-get remove ...my plugins, in case there was some clash
  • apt-get purge nautilus gnome-session ubuntu-desktop
  • apt-get install nautilus gnome-session ubuntu-desktop

Then I rebooted, and the search feature is now working.
Nautilus Notes was still working, so I then reinstalled my plugins,
and everyghing is working fine again.

There may have been no need to uninstall my plugin, but as it turned out, it doesn't matter; eaither way works... (I've been without this feature for 3 months... Today was the day !

  • I tried but it didN_# work for me. I'll ask another question ... – piedro Jan 28 '11 at 10:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.