I've been using Ubuntu 12.04 64 bit for about 2 weeks now and I installed the latest Fglrx driver (Graphics Card- AMD HD 3200, PC- Acer Aspire 5336, 4GB RAM, 500GB Harddrive). The problem is that sometimes video's lag and play out of sync sometimes the windows take long to show up after I've clicked them etc. After looking around I found a video on Youtube by Ubuntu help guy and in the video he recommended using an older driver if you have an older graphics card, his was about 4 years old (same as mine) and he used the 11.10 catalyst driver so I decided to try it.

I removed the previous installation of the driver and then installed the 11.10 driver. However, when I restarted it instead of going to the GUI it goes to a terminal like window and asks for my login. Now its pretty clear I need to remove the old driver and go back to using the latest one. The only problem is I'm not sure where I saved the latest driver and in order to connect to the Internet I need to change /etc/resolv.conf (I use a static IP). So what should I do?

Also anyone from personal experience, what propitiatory driver works best with my graphics card? As in the version.


In order to do that I need to connect to the Internet and since I use a static IP I normally use gedit to edit the /etc/resolv.conf file with my DNS server but I can't do that now because I can't open gedit. Anyway now I uninstalled the fglrx driver and I've managed to get to the login screen but when I login the screen goes black for a few seconds and then just returns to the login screen. Help! Btw the first post was made without an account now I've decided to make an account.

  • Switch to a TTY console (Alt + Ctrl + F1) and try to edit the file you mention from there (for example using vi, pico ...) – Melon Dec 17 '12 at 11:23

have you tried to use the latest driver for your ati graphic card ... i had the same problem as you when i installed the latest version it worked perfectly . (i have run Call of duty mw3 on my laptop)

for installing it use this commands:

sudo add-apt-repository ppa:makson96/fglrx

sudo apt-get update

sudo apt-get upgrade

sudo apt-get install fglrx-legacy

for removing it if you get any problem you can use this commands :

sudo apt-get install ppa-purge

sudo ppa-purge ppa:makson96/fglrx

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.