I have an Asus r1f laptop. For some reason, hibernate/sleep isn't working properly at all. Are there any other packages I can use or tweaks I can implement to get this working?

I've googled around and this appears to be an issue with some laptops and their need for proprietary drivers. Is this true? Is there anything I can do?

3 Answers 3


You can try to put the name of your proprietary module (nvidia or fglrx (for ATI) are most likely) in the quotes in MODULE="" in the /etc/default/acpi-support file and reboot.

sudo nano /etc/default/acpi-support

This'll make that module unload before suspend and reload after suspend. It sometimes works, but it's also possible that you have just plain buggy drivers somewhere and need to file a kernel bug.

EDIT: It's also very possible that you've just plain found a bug. If you think that's the case, please file it: ubuntu-bug linux

  • Do you know how to lookup modules? I believe my graphics driver is of the integrated Intel variety. If it's video related I'd like to try this. Aug 14, 2010 at 14:39
  • 1
    Intel drivers are not proprietary, that's why all of my machines have them. Broadcom wireless drivers are proprietary... lsmod will give you a list of all modules currently loaded.
    – maco
    Aug 14, 2010 at 17:18

You should try µswsusp. From the Wikipedia article:

uswsusp (userspace software suspend) is a suspend-to-ram and suspend-to-disk implementation for the Linux operating system, compatible with kernels 2.6.17 and onwards. It supports both s2ram ("standby") and s2disk ("hibernate"), as well as a mode called "s2both", which saves state to disk and RAM. S2both is intended for use in low-battery situations where restoring from ram is desired but can't be relied on as the battery may fail causing a restore from disk to be necessary.

The package is available in the Ubuntu Software Center.

  • 1
    my laptop isn't supported :( using the --force option doesn't appear to work at all either. I'll keep messing with this a bit longer and report back. Aug 14, 2010 at 14:37
  • didn't work for me :( Jul 21, 2011 at 23:12
  • 1
    @Nigel Thorne: it would be more helpful if you described the exact steps you did and how it manifested when it didn't work (i.e. it didn't hibernate, it didn't resume from hibernate, etc)
    – Li Lo
    Aug 1, 2011 at 21:00

Are you install your ubuntu with regular installation or use wubi installer?

Compared with a regular installation, a Wubi installation faces some limitations. Hibernation is not supported and the filesystem is more vulnerable to hard reboots.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .