I've been using Ubuntu for years now and starting about last week I started seeing some problems. Ubuntu has constantly been freezing when I try to open stuff. Or the screen will freeze for about 5-7 seconds.

For instance, when I'm in a terminal it will run smooth, but when I hit the bottom of the terminal and all the text needs to move up, the process freezes for 5-7 seconds. However I know it's responding because the screen doesn't gray out and I can still move my mouse.

(That is just one example) I installed the latest Nvidia drivers about 4 days before this happened. It was running amazingly with those drivers. So I don't think that's the problem. (I tried downgrading just in case and it didn't help) I've been dealing with this for about a week and a half. The problems started when I was using 12.04 64-bit.

I've been using 12.10 64-bit since last Friday. Today I turned my computer on and Ubuntu told me it had some errors on the disk so I let it fix them. Now when I boot up my computer is slower than ever. It hangs 5-7 seconds when I do so much as click on a menu. It takes 8 seconds for the command ls to work. I would reformat to try and fix, but I'm on a work computer and I have a lot of stuff on here.

I've tried using Unity, gnome, gnome classic with/without effects. Same problem on all of them.

I am on a Dell Precision laptop

  • i7 processor
  • nvidia QUADRO 3000m
  • 8GB of RAM
  • 500GB HDD x2

System monitor shows that the system is running fine and isn't peaking anywhere.

PS: When I boot from CD, everything runs normal again.

  • 2
    I/O errors, corrupted file systems, a dying hdd will all impact performane. That's probably the core of the problem, with all the other info irrelevant. – mikewhatever Nov 29 '12 at 15:30

Try reinstalling the graphic driver,if it doesnt work try reinstalling ubuntu, if it still doesnt work.....well consider checking your HDD,good luck

  • Posting answer here temporarily cuz i can't post for another 7 hours Alright. I figured it out. This must have some how gotten changed when i installed the latest nvida driver. Either that, or I'm a loser and changed it myself. Posting what i did to solve my problems Open "nvidia x server settings" Your GPU>PowerMizer> Preferred mode - set to prefer maximum performance. Then face palm yourself for not figuring this out sooner. – Jay Nov 29 '12 at 15:42

First, I have to say it for the whole world. BACK UP YOUR DATA!!! Use back in time, deje dupe, rsync, or just copy files. Problems like this are a good reason why. This is even more important in business land. It's sooooo easy to do, there's literally no reason not to. Sorry juts had to get that in. Occupational hazard I guess. On to actually being helpful.

It sounds like you have a timeout happening. That you end up "waiting" for that timeout, then continuing on. Here are some things that I would check.

  • Check /var/log/messages and make sure your not getting an error there. If you are, fix it. You can also use dmesg.
  • Check that you have freespace and inodes. df -h and df -i should do the trick.
  • Run fsck manually from recovery mode. Maybe there are more errors.
  • Check your sound card and nic (or other "extra") hardware, make sure there fine and, for testing, disable power savings. I have seen both cause issues like you describe (though not out of the blue like that).
  • Unmount everything that is not needed to run the OS, and try ls again. That type of freezing sounds a lot like bad networks share.
  • If all else fails, mount the drive using a liveCD (not recovery mode) and try browsing around the disk, and issuing your ls again. You may have a bad hard drive.
  • Thanks for you answers guys! Very quick responses. I actually solved it myself by some miracle. But i can't answer my own questions for another... 7 hours. Thanks again – Jay Nov 29 '12 at 15:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.