1

Possible Duplicate:
Cannot boot because: Kernel panic - not syncing: Attempted to kill init!

I updated Ubuntu and when I rebooted, it won't boot. I get a black screen with the error Kernel panic - not syncing:Attempted to kill init

I use Ubuntu 12.04, my linux-image is 3.2.0-33-generic-pae,recovery mode goes into the same error (Kernel panic - not syncing:Attempted to kill init) and Ubuntu upgraded my previous linux versions as well and they all go into that same error.

marked as duplicate by Jorge Castro, Eric Carvalho, Eliah Kagan, fabricator4, user76204 Jan 8 '13 at 14:30

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

Hi you may load Ubuntu by selecting previous version and than selecting the corresponding kernel in that option. The problem generally arises when you have 64-bit kernel and updating causes a generic-pae 32-bit kernel to apear along with the previous one. Thus causing the problem.

Once you are able to boot, you may remove the generic-pae kernel by the following steps:

  1. sudo update-grub. It will show you grub.cfg file and you can see the two kernels present.

  2. sudo rm /boot/*generic-pae

  3. sudo update-grub

-1

Maybe reinstalling OS is the best (no time consuming) choice on this type of messages. There is another similar problem: Cannot boot because: Kernel panic - not syncing: Attempted to kill init! fixed with reinstall OS.

  • Before I reinstall the OS, how can I backup my Ubuntu data so it won't get lost? – Neftali Adrian Nov 29 '12 at 16:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.