2

Since last week shutdown has stopped working in my system. Either i use the shutdown menu in Unity/LightDM or use sudo shutdown -h now the system just locks, and i can't either use Alt+reisub. Only a hard shutdown works.

If i shutdown from a tty, this is the last output i get before the system freezes:

umount: /run/lock: not munted
umount: /run/shm: not mounted
mount: / is busy
* Will now halt
[...] Power down.

After this the disk usage led turns on and i can't do anything else.

What could be the problem?

What i have tried

  • set acpi=force in GRUB doesn't help;
  • check for errors in the shutdown process: i get any error at all during shutdown, except the lines stated on top;
  • acpid is installed.
  • reboot/suspend works just fine!

Edit

As seen here i get some warnings regarding ACPI in /var/log/boot.log.

  • mount: / is busy... what? You sure you didn't install any packages that might have interfered with the shutdown? – MiJyn Nov 28 '12 at 21:07
  • yes i have, but are all packages that should have nothing with the shutdown process: latex, vala, text editors, etc. Maybe the problem was originated by some update? I will try booting with other kernel – Salem Nov 28 '12 at 21:19
  • Also run the system updates again :) – MiJyn Nov 28 '12 at 21:19
4

The problem is a bug, and it is caused by no just one service, but a set of these, see this tread for further information.

Most likely dnsmasq, dhclient, modem-manager and network-manager are the involved services.

1

Simple solution that worked for me

Before shutting down, click on network icon on the top system tray and uncheck "Enable Networking".

PS. I'm a linux noob. Discovered this trick from this thread.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.