7

I am using Ubuntu 10.10 and having trouble setting a custom icon for an application launcher that I created. I have created and SVG file and placed it in /usr/shared/icons/hicolor/scalable/apps/ and when I try to select it as the icon for the application launcher, it just goes back to the gnome-panel-launcher.svg default.

If I put the SVG file on my desktop and then select it, all is well. I'm assuming this is some type of permission problem, but I cannot seem to figure it out. I have set the permissions to be identical to the other icons in /usr/shared/icons/hicolor/scalable/apps/, but have no luck doing that either.

  • Did you verify that YOUR user has read/write permissions to the scalable/apps folder? i mean same user, group, chmod permissions, chown permission. just to be 100% sure. – Luis Alvarado Jan 19 '11 at 18:46
  • 1
    @CYREX Your user does not need to have write permissions to any icon folder to use the icon in a launcher. – Isaiah Jan 19 '11 at 18:48
  • @CYREX all of the icons and folders are owned by root, which is the default, and I am able to set any of the other icons for the application launcher. – Jared Jan 19 '11 at 19:00
  • 1
    @CYREX First time I did sudo cp myicon.svg /usr/share/icons/hicolor/scalable/apps/. Then I did gksudo nautilus and copied it that way. Neither way worked for me. – Jared Jan 19 '11 at 19:15
  • 1
    It may have something to do with the icon-finding behaviour. If you specify an icon in /usr/share/icons/hicolor/scalable/apps/ (and possibly other folders under apps/), it will search for that icon name in your current theme; I don't know what happens if it can't find it. What happens if you put it in /usr/share/pixmaps? – zpletan Jan 19 '11 at 20:28
4

I think you also need to Provide PNG versions in 16x16,24x24,36x36,48x48 ect. folders. Not just scalable! Maybe you can try the ubuntu-mono-light and ubuntu-mono-dark folders :)

  • 1
    That seems to have worked. I didn't verify that you must also provide the PNG versions, but by placing it in a different folder, I was able to set the custom icon. Thanks for your help! – Jared Jan 19 '11 at 20:52
  • No Problem I like to help :) – Micheal Harker Jan 19 '11 at 20:54
  • FYI I also had to grant full read permissions in order to get this to work (gou+r) – Jonathan Neufeld Aug 2 '16 at 16:04
0

I had no luck with .png, but a 64x64 .jpg worked! (Ubuntu Trusty, Gnome)

YMMV, so this is what my system is:

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=14.04
DISTRIB_CODENAME=trusty
DISTRIB_DESCRIPTION="Ubuntu 14.04.5 LTS"

Linux *** 4.4.0-83-generic #106~14.04.1-Ubuntu SMP Mon Jun 26 18:10:19 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

GNOME Shell 3.10.4

I had to kill gnome-panel to see the new icons on the panel:

ps aux | grep gnome-panel

shows you the PID:

me        2397  0.0  0.3 738108 56688 ?        Sl   Nov30   2:39 gnome-panel
me       22210  0.0  0.0  18420  2100 pts/43   S+   13:16   0:00 grep --color=auto gnome-panel

and

kill 2397

does the trick. The killed panel automatically restarts in seconds.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.