I have installed an app from the software center that is called Matlab. But then it turns out that it isn't actually Matlab, but some support package for it, and I when I try to remove it, it opens a new window asking for the directory of Matlab. I can't close it except by force, and every time I try to install a new app, it appears, and prevents the app from installing.

I've searched around Google, and lots of forums, but no answer related to this app, only the actual Matlab. I tried searching for the app in File System, and deleted the Matlab.desktop and still the problem didn't go away. This app has no actual directory in the file system, and it is quite annoying. Even when I tried app update, it appears after the download has finished, thus preventing the installation.

Now I could try to install the actual Matlab, which I'm currently downloading, but it takes too much space, and I barely have that space, because I've dual booted with Windows 7 and I have only 18 GB for Ubuntu and the rest of the 400 GB Windows. Has anyone faced this problem before, and does anyone know how to fix this?


Okay, when you have a problem like this, where you can't remove an application via the Ubuntu Software Center, the best way (IMHO) is to purge it via the terminal. Don't worry, it actually isn't that hard :)

First, you need to find the package name. This can be done by either looking at the "Version" property of an application in the Ubuntu Software Center (the first part, not the second), or you can search for it in the terminal, like so (replacing Package Name by Matlab, in your case):

sudo apt-cache search Package Name

and find the most relevant package name (you might find a couple, and if that is the case, use them all for the next step)

Next, you have to remove the offending package(s). To do so, run this command:

sudo apt-get purge pkg1 pkg2 pkg3

Let's say, for example, you installed freemat (a version of matlab, I am not sure if this is what you installed or not though), you would type this in:

sudo apt-get purge freemat

Hope this helps!

EDIT: I re-read your problem, and it's actually caused by a failed installation of Matlab. The steps above should fix it :)


Just run

sudo apt-get purge matlab-support

This command will purge matlab-support and fix your problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.