This question already has an answer here:

Whenever I close Pidgin it stopped showing in system tray (after the upgrade from 12.04 to 12.10). The setting is "show system tray: always" in Pidgin.

merged by fossfreedom Apr 7 '13 at 21:50

This question was merged with How do I enable the pidgin system tray icon? because it is an exact duplicate of that question.