Over night I tried to upgrade to (k)ubuntu 12.10. Unfortunately kdm (neither lightdm) doesn't show up after boot. I found several posts describing errors due to the migration from kdm to lightdm. Some sugest reinstallation of kdm. Therefore I logged into a shell and tried to install it using apt-get. However it turned out that network is not available. ifconfig showes that only the loopback device lo is available. What can I do to get lan or wlan network working on the commandline? I relized that grub still runs the old tuxonice kernel which I installed from ppa. Is it possible that the installation didn't finish and left me in an inkonsistent state in which the kernel version does not match the modules? How can I proceed the installation from the downloaded packages?

  • Try choosing another kernel in Grub from the second option in the menu. – To Do Nov 28 '12 at 10:35
  • There are two older (tuxonice) 3.2 kernels. Unfortunately with neiter of them I get a working network. – highsciguy Nov 28 '12 at 10:42
  • I am trying to find out where apt-get stores the downloaded packages. If it downloaded the 3.5. kernel I could install it using dpkg. Any ideas? – highsciguy Nov 28 '12 at 10:44
  • Thats obviously /var/cache/apt/archives/. I find that apt-get didn't download any linux-image. Isn't this strange? – highsciguy Nov 28 '12 at 10:48
  • Do you have a 12.10 liveUSB or liveDVD? Try seeing if this works properly. If it does, you may consider downloading manually the kernel deb's, installing it and then remove the tuxonice ones. – To Do Nov 28 '12 at 10:57

The upgrade entailed several different problems which I finally managed to fix:

The upgrade was incomplete. Important packages including the new kernel where not even downloaded. This left the system in an inconsistent state. It was possible to boot the system with one of the old kernels. On a different system I downloaded the kernel packages


from http://packages.ubuntu.com/ and saved them on USB storage.

I mounted the storage from the command line

sudo mount -t ext3 /dev/sdb1/ mountpoint

and installed them using

dpkg --force-all -i mountpoint/linux-*

I booted the new kernel and got the network working which appeared in

sudo lshw -C network

as DISABLED. I got it working with

sudo modprobe -v r8169

which loads the kernel module for my network card. However only upon

sudo dhclient eth0

eth0 appeared in the ifconfig list and in sudo lshw -C network. As I could connect to the internet now I fixed the upgrade with

sudo apt-get -f upgrade
sudo apt-get update
sudo apt-get upgrade

I had to install several blocked packages with sudo apt-get install [packagename]. And individual ones (in particular one calligra package) with dpkg -i /var/cache/apt/archives/[package] as they had conflicts (common files with different package).

Finally I could boot the complete system but the login manager lightdm still didn't work. Lightdm shows (this is a known bug) a message "low graphics mode". I had to install the package lightdm-kde-greeter and to set greeter-session=lightdm-kde-greeter in the lightdm.conf file.

Finally I had to reinstall sound and graphics related packages to get it those again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.