5

I'm getting this error when I run gtk-redshift from the CLI (it just doesn't start if I start it from the GUI):

(process:3862): GLib-GObject-CRITICAL **: g_type_instance_get_private: assertion `instance != NULL && instance->g_class != NULL' failed

If I run redshift, I also get the same error as above, followed by this:

Segmentation fault (core dumped)

I'm running redshift version 1.7 and Xubuntu 12.10.

11

You may need create a config file to avoid the crash..

Create a file named redshift.conf and save it into ~/.config/redshift.conf. Here you have an example to create the config file:

; Global settings
[redshift]
temp-day=5700
temp-night=3500
transition=1
gamma=0.8:0.7:0.8
location-provider=manual
adjustment-method=vidmode

; The location provider and adjustment method settings
; are in their own sections.
[manual]
lat=-34.6
lon=-58.3

;screen
[vidmode]
screen=0

To know the coordinates for your city you can use itouchmap. Just search for your place and write down the numbers.
eg: My city Buenos Aires is lat=-34.6 and lon=-58.3

Once you have created the redshift.conf file, run the application and see if it works. You can find additional information about commands, config file, values on the Redshift website...

1
  • 1
    @Roman Raguet: Thanks! I just want to add that this worked for Lubuntu (my version is 13.10). It seems the name of the file to be created should be "redshift.conf" – pablofiumara Nov 3 '13 at 18:51
0

You can also just run it directly from the command line, no configuration needed:

redshift -l manual -l "52.05:-1.05" -t 5000:1100

This sets the position to manual (instead of using geoclue), and use the coordinates to set the latitude (north-south) to 52.05, and the longitude (east-west) to -1.05. You can find your position (though, a position nearby will do) manually using Google Maps, or similar: a wood some distance away

To stop it you can use

killall redshift

For more info, run redhsift -h.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.